asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abdullah alamoudi <bamou...@gmail.com>
Subject Re: CheckStyle Errors in Eclipse?
Date Wed, 29 Jun 2016 03:04:32 GMT
Taewoo,

For (1), I ran into this issue sometime ago when I installed some plugin
(can't remember the name). You need to uninstall it basically
For (2), there is no way to have break points in functions since there is
generated bytecode to handle cases such as nulls and missing in a generic
way. This effectively change the Function to FunctionGen which is different
from the function.

Hope that helps,
Abdullah.

On Wed, Jun 29, 2016 at 5:13 AM, Taewoo Kim <wangsaeu@gmail.com> wrote:

> Hello All,
>
> I'm struggling with these two issues for several days. Any help will be
> appreciated. Thanks!
>
> 1) I have upgraded m2e connector and since then, Eclipse shows about
> 100,000 errors. The category is Checkstyle issue. I searched the Google and
> deactivated the Checkstyle. But, that was a temporary solution. When I
> refresh the Maven project, the check is always conducted. Does anyone know
> the solution to this issue?
>
> 2) Another issue is that some of generated classes are being used during
> runtime execution. But, I Eclipse can't find the source file for that class
> during a debug process. For example, GreaterThanDescriptor class is
> generated
> under
> asterixdb/asterix-runtime/target/classes/org/apache/asterix/runtime/evaluators/comparisons
> directory. However, when I put a break point in the class, Eclipse can't
> find the corresponding source file and the class name is shown as
> GreaterThanGen class.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message