asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Blow <mblow.apa...@gmail.com>
Subject Re: AsterixDB build now requires Maven 3.3.9
Date Sun, 19 Jun 2016 00:46:14 GMT
Yes, as both Jenkins and I were already running with 3.3.9, the new
requirement was not noticed until reported by a dev post-merge. Had it been
realized, we certainly would have tried to give ample notice.

Thanks,

-MDB

On Sat, Jun 18, 2016 at 6:38 PM Till Westmann <tillw@apache.org> wrote:

> I think that the "problem" was that the toolchain change was noticed
> only
> after the commit to master as both the dev machine and the jenkins boxes
> were running a version of mvn that worked.
>
> Maybe we should run with the minimal documented maven (and JDK) version
> on
> the jenkins boxes to make sure that we don't run into this again?
> Thoughts/concerns?
>
> Thanks,
> Till
>
> On 17 Jun 2016, at 2:18, Chris Hillery wrote:
>
> > FYI, my email in the past about upgrading Maven on Ubuntu no longer
> > works
> > for 3.3.9. I've found another PPA:
> >
> > https://launchpad.net/~andrei-pozolotin/+archive/ubuntu/maven3
> >
> > Request: In the future, can we have announcements to the list and
> > discussion at least a few days *before* committing changes which
> > require
> > toolchain upgrades?
> >
> > Ceej
> > aka Chris Hillery
> >
> > On Wed, Jun 15, 2016 at 11:12 AM, Michael Blow
> > <mblow.apache@gmail.com>
> > wrote:
> >
> >> We're not currently, but this is a great idea- I'll add this.
> >>
> >> Thanks,
> >>
> >> -MDB
> >>
> >> On Wed, Jun 15, 2016 at 1:36 PM Preston Carman <prestonc@apache.org>
> >> wrote:
> >>
> >>> Thanks for the heads up. Are we using the "maven-enforcer-plugin"?
> >>> The
> >>> plugin can check for a required version of maven. It has been
> >>> helpful
> >>> with another project that would give odd errors if you were using an
> >>> older version of maven.
> >>>
> >>> On Wed, Jun 15, 2016 at 10:08 AM, Michael Blow
> >>> <mblow.apache@gmail.com>
> >>> wrote:
> >>>> All,
> >>>>
> >>>> A change to break the build if hard-tabs are present in source
> >>>> files
> >> has
> >>> a
> >>>> dependency on the latest version of maven.  Older versions have
> >>>> been
> >>>> reported to fail with an error similar to:
> >>>>
> >>>> Failed to execute goal
> >>>> org.apache.maven.plugins:maven-checkstyle-plugin:2.17:check
> >>> (verify-style)
> >>>> on project apache-asterixdb-hyracks: Unable to parse configuration
> >>>> of
> >>> mojo
> >>>> org.apache.maven.plugins:maven-checkstyle-plugin:2.17:check for
> >> parameter
> >>>> sourceDirectories: Cannot assign configuration entry
> >> 'sourceDirectories'
> >>>> with value
> >>>>
> >>>
> >>
> '<>/asterixdb/hyracks-fullstack/src/main/java,<>/asterixdb/hyracks-fullstack/src/test/java'
> >>>> of type java.lang.String to property of type java.util.List ->
> >>>> [Help 1]
> >>>>
> >>>> Please ensure you are running with Maven 3.3.9 to avoid this issue.
> >>>>
> >>>> Thanks,
> >>>>
> >>>> -MDB
> >>>
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message