asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Blow <mblow.apa...@gmail.com>
Subject AsterixDB build now requires Maven 3.3.9
Date Wed, 15 Jun 2016 17:08:52 GMT
All,

A change to break the build if hard-tabs are present in source files has a
dependency on the latest version of maven.  Older versions have been
reported to fail with an error similar to:

Failed to execute goal
org.apache.maven.plugins:maven-checkstyle-plugin:2.17:check (verify-style)
on project apache-asterixdb-hyracks: Unable to parse configuration of mojo
org.apache.maven.plugins:maven-checkstyle-plugin:2.17:check for parameter
sourceDirectories: Cannot assign configuration entry 'sourceDirectories'
with value
'<>/asterixdb/hyracks-fullstack/src/main/java,<>/asterixdb/hyracks-fullstack/src/test/java'
of type java.lang.String to property of type java.util.List -> [Help 1]

Please ensure you are running with Maven 3.3.9 to avoid this issue.

Thanks,

-MDB

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message