asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Preston Carman <prest...@apache.org>
Subject Re: AsterixDB build now requires Maven 3.3.9
Date Wed, 15 Jun 2016 17:36:50 GMT
Thanks for the heads up. Are we using the "maven-enforcer-plugin"? The
plugin can check for a required version of maven. It has been helpful
with another project that would give odd errors if you were using an
older version of maven.

On Wed, Jun 15, 2016 at 10:08 AM, Michael Blow <mblow.apache@gmail.com> wrote:
> All,
>
> A change to break the build if hard-tabs are present in source files has a
> dependency on the latest version of maven.  Older versions have been
> reported to fail with an error similar to:
>
> Failed to execute goal
> org.apache.maven.plugins:maven-checkstyle-plugin:2.17:check (verify-style)
> on project apache-asterixdb-hyracks: Unable to parse configuration of mojo
> org.apache.maven.plugins:maven-checkstyle-plugin:2.17:check for parameter
> sourceDirectories: Cannot assign configuration entry 'sourceDirectories'
> with value
> '<>/asterixdb/hyracks-fullstack/src/main/java,<>/asterixdb/hyracks-fullstack/src/test/java'
> of type java.lang.String to property of type java.util.List -> [Help 1]
>
> Please ensure you are running with Maven 3.3.9 to avoid this issue.
>
> Thanks,
>
> -MDB

Mime
View raw message