asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raman Grover <ramangrove...@gmail.com>
Subject Re: Question with AsterixDB configuration
Date Tue, 05 Apr 2016 17:28:08 GMT
One of the known reasons for the above error message is the *improper
extraction of the asterix-installer binary zip*. The archive contains a
hidden directory that contains internal scripts used by managix; these are
used internally by managix to validate an environment. If the binary is
auto-extracted upon download, the browser can skip the hidden files (chrome
is known to do this). To confirm if this is indeed the case...  *please
execute ls -a inside the managix_home directory and share the output.* If
the output doesn't contain a .installer directory, it validates the above
hypothesis. The *solution *is to use command line tool (e.g. unzip) to
extract the installer binary.

Let us know.

Regards,
Raman

On Tue, Apr 5, 2016 at 10:14 AM, Mike Carey <dtabass@gmail.com> wrote:

> Widening to include the AsterixDB user and developer communities....
> I don't remember what this actually ended up being due to - it was a
> misleading error msg for sure.
>
> @Folks?
>
> Cheers,
> Mike
>
>
> On 4/5/16 6:30 AM, Yu Zhao wrote:
>
>> Hi~
>>
>> I'm trying to install AsterixDB on my mac (OSX 10.11.3) and there is a
>> strange issue about SSH password-less configuration. I’ve followed all the
>> steps in the guide, and I seem have password-less SSH configured
>> /$ ssh 127.0.0.1
>> Last login: Tue Apr 5 21:05:48 2016
>> $ exit
>> logout
>> Connection to 127.0.0.1 closed.
>> /
>> But I still have this configuration error
>> /$ managix validate
>> INFO: Environment [OK]
>> ERROR: Password-less SSH (from user account: Z ) not configured for the
>> following hosts
>> 127.0.0.1
>> FATAL: Managix Configuration [ERROR] /
>>
>> JDK is 1.8 instead of 1.7 in the document though I don’t think this is
>> the problem.
>> /$ java -version
>> java version "1.8.0_65"
>> Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
>> Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode) /
>>
>> I’ve googled and so far I have no idea how to solve this. I’m mailing to
>> you because your mail showed you had the same problem 2 months ago and I
>> think maybe now you have the solution, which would be great.
>>
>> Thank in advance for any help.
>>
>>
>


-- 
Raman

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message