asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abdullah alamoudi <bamou...@gmail.com>
Subject Re: Maven/Jenkins Help Needed
Date Thu, 11 Feb 2016 10:06:49 GMT
Nevermind, figured out a way to make it work

Cheers,
Abdullah.

Amoudi, Abdullah.

On Thu, Feb 11, 2016 at 12:11 PM, abdullah alamoudi <bamousaa@gmail.com>
wrote:

> Hi Dev,
> I am having one of those situations where everything works on my machine
> but when I run the tests on Jenkins, it doesn't. Here are the details:
>
> I have added external library tests to asterix-app. Since the tests need
> to install an external library, they need to access the zip file produced
> by asterix-external-data. The needed file is located at:
> asterix-external-data/target/testlib-zip-binary-assembly.zip
>
> I have tried to access the file using relative path
> ../asterix-external-data/target/testlib-zip-binary-assembly.zip through
> some custom code, or copying the zip file using the maven-resources-plugin
> both of which work fine on my machine but I keep getting file not found on
> Jenkins.
>
> The thing is, I see that asterix-installer does something similar without
> any issues.
> Any idea on how to solve this?
>
> Amoudi, Abdullah.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message