asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raman Grover <ramangrove...@gmail.com>
Subject Re: Support for push twitter feed adaptor in 0.8.6
Date Wed, 13 Jan 2016 18:26:22 GMT
Vignesh,

It is a known issue in the AsterixDB installed (Managix) wherein it is
unable to retrieve the process IDs corresponding to the CC and NC JVMs and
falsely assumes the cluster to be unhealthy.

I would ask you to confirm using either (a) jps on terminal (b) navigating
to webUI whether Managix is falsely reporting the state or not.

Regards,
Raman

PS: The issue in managix is arising from the pattern matching it applies to
retrieve the process IDs.

On Tue, Jan 12, 2016 at 9:03 PM, abdullah alamoudi <bamousaa@gmail.com>
wrote:

> Vignesh,
> The error message indicates that the cluster controller didn't start
> correctly.
> Did you have data in the previous installation (0.8.6) ? If so, then there
> are some compatibility issues that probably caused the cluster startup to
> fail.
>
> One thing that would help us to identify the exact cause is the log files.
> can you share them with us?
> You can get them using the command:
>
> managix log -n <instance_name>
>
> Regards,
> Abdullah.
>
>
> Amoudi, Abdullah.
>
> On Wed, Jan 13, 2016 at 4:28 AM, Vignesh Raghunathan <
> vignesh.raghunathan90@gmail.com> wrote:
>
> > Hi,
> >
> > I've been trying to install AsterixDB with the above mentioned changes in
> > a cluster but I get the following error
> >
> > WARNING!:Cluster Controller not running at node0
> >
> > The cluster earlier had AsterixDB 0.86 installed. I haven't changed the
> > configurations of the cluster and I am using the same cluster
> configuration
> > file. Should I perform some manual cleanup before installing the later
> > version in a system which had 0.86 installed?
> >
> > I have attached the cluster configuration file for reference.
> >
> > Thanks,
> >
> > Vignesh
> >
> > On Thu, Jan 7, 2016 at 8:05 AM, abdullah alamoudi <bamousaa@gmail.com>
> > wrote:
> >
> >> Just to clarify,
> >> The Twitter adapter was working until I did some cleanup work (last
> week)
> >> in external data land and so the adapter was hidden.
> >>
> >> I have submitted a change and if someone is eager to use it, it can be
> >> checked out through:
> >> git fetch https://asterix-gerrit.ics.uci.edu/asterixdb
> >> refs/changes/74/574/1 && git checkout FETCH_HEAD
> >>
> >> Duplicate key errors (in feeds) will result in a deadlock until we
> figure
> >> it out (which is what I am doing right now). Querying the adapters will
> >> not
> >> show the twitter adapter though because It is not an adapter anymore. it
> >> is
> >> a data source. The example in the documentation will still work though.
> >>
> >> Cheers,
> >> Abdullah.
> >>
> >> Amoudi, Abdullah.
> >>
> >> On Thu, Jan 7, 2016 at 10:27 AM, abdullah alamoudi <bamousaa@gmail.com>
> >> wrote:
> >>
> >> > Vignesh,
> >> > The most recent version doesn't have the push_twitter adapter (meaning
> >> > that, when you query the adapters, you will not see it.) but its alias
> >> is
> >> > still there in the system.
> >> >
> >> > I have looked at the current master after your question and found out
> >> why
> >> > it didn't work. I fixed it on my branch and I am pushing it for review
> >> > along with other feed fixes later tonight.
> >> >
> >> > TL,DR, It doesn't work right now but should be working tomorrow :)
> >> >
> >> > Cheers,
> >> > Abdullah.
> >> >
> >> >
> >> > Amoudi, Abdullah.
> >> >
> >> > On Thu, Jan 7, 2016 at 10:16 AM, Vignesh Raghunathan <
> >> > vignesh.raghunathan90@gmail.com> wrote:
> >> >
> >> >> My installation does not have the push_twitter adaptor. I'll use a
> more
> >> >> recent version then. Thank you for the response.
> >> >>
> >> >> On Thu, Jan 7, 2016 at 12:14 AM, Raman Grover <
> ramangrover29@gmail.com
> >> >
> >> >> wrote:
> >> >>
> >> >> > correction...
> >> >> > include the statement below before running the queries.
> >> >> >
> >> >> > use dataverse Metadata;
> >> >> >
> >> >> > On Wed, Jan 6, 2016 at 10:43 AM, Raman Grover <
> >> ramangrover29@gmail.com>
> >> >> > wrote:
> >> >> >
> >> >> > > I believe, the push based twitter adaptor was introduced
in 0.8.7
> >> >> (prior
> >> >> > > version had the pull based adaptor)
> >> >> > >
> >> >> > > The set of adapters  available with an asterixDB installation
can
> >> be
> >> >> > > looked up using the following query
> >> >> > > for $x in dataset DatasourceAdapter
> >> >> > > return $x
> >> >> > >
> >> >> > > OR
> >> >> > >
> >> >> > > use the query below to look up the adaptor you are wishing
to
> use.
> >> >> > >
> >> >> > > for $x in dataset DatasourceAdapter
> >> >> > > where $x.Name='push_twitter'
> >> >> > > return $x
> >> >> > >
> >> >> > >
> >> >> > > Can you confirm (using above) if your installation has the
> >> >> push_twitter
> >> >> > > adaptor built-in?
> >> >> > >
> >> >> > > Regards,
> >> >> > > Raman
> >> >> > >
> >> >> > > On Wed, Jan 6, 2016 at 10:10 AM, Vignesh Raghunathan <
> >> >> > > vignesh.raghunathan90@gmail.com> wrote:
> >> >> > >
> >> >> > >> I used the statements in the tutorial for data feeds
in 0.8.7
> >> >> > >> documentation
> >> >> > >>
> >> >> > >>
> >> >> > >>
> >> >> >
> >> >>
> >>
> https://asterixdb.incubator.apache.org/docs/0.8.7-incubating/feeds/tutorial.html
> >> >> > >>
> >> >> > >> Thank you
> >> >> > >>
> >> >> > >> On Wed, Jan 6, 2016 at 10:05 PM, abdullah alamoudi <
> >> >> bamousaa@gmail.com>
> >> >> > >> wrote:
> >> >> > >>
> >> >> > >> > Vignesh,
> >> >> > >> > Can you share with me the exact statements you used
and I will
> >> be
> >> >> sure
> >> >> > >> to
> >> >> > >> > help you.
> >> >> > >> >
> >> >> > >> > Cheers,
> >> >> > >> > Abdullah.
> >> >> > >> >
> >> >> > >> > Amoudi, Abdullah.
> >> >> > >> >
> >> >> > >> > On Wed, Jan 6, 2016 at 7:03 PM, Vignesh Raghunathan
<
> >> >> > >> > vignesh.raghunathan90@gmail.com> wrote:
> >> >> > >> >
> >> >> > >> > > Hi,
> >> >> > >> > >
> >> >> > >> > > After creating a twitter feed, I am getting
the following
> >> error
> >> >> if I
> >> >> > >> try
> >> >> > >> > to
> >> >> > >> > > connect the feed to a dataset.
> >> >> > >> > >
> >> >> > >> > > unable to create adapter  java.lang.ClassNotFoundException:
> >> >> > >> > > push_twitter [AlgebricksException]
> >> >> > >> > >
> >> >> > >> > >
> >> >> > >> > > Isn't the push twitter feed adaptor supported
in 0.8.6?
> >> >> > >> > >
> >> >> > >> > > Thanks,
> >> >> > >> > > Vignesh
> >> >> > >> > >
> >> >> > >> >
> >> >> > >>
> >> >> > >
> >> >> > >
> >> >> > >
> >> >> > > --
> >> >> > > Raman
> >> >> > >
> >> >> >
> >> >> >
> >> >> >
> >> >> > --
> >> >> > Raman
> >> >> >
> >> >>
> >> >
> >> >
> >>
> >
> >
>



-- 
Raman

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message