asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Till Westmann" <ti...@apache.org>
Subject Re: Maven3 no longer supports Metaversion
Date Wed, 25 Nov 2015 16:17:03 GMT
Thanks. I filed an issue [1] so this doesn’t get lost.

Cheers,
Till


[1] https://issues.apache.org/jira/browse/ASTERIXDB-1199

On 25 Nov 2015, at 1:11, Wail Alkowaileet wrote:

> Hi,
>
> I ran into a small issue when trying to resolve the parent pom in 
> asterix
> and fullstack modules with Scala-sbt.
>
> I got the error:
> io problem while parsing ivy file:
> /home/cces/.m2/repository/org/apache/asterix/asterix/0.8.8-SNAPSHOT/asterix-0.8.8-SNAPSHOT.pom:
> Impossible to load parent for
> file:/home/cces/.m2/repository/org/apache/asterix/asterix/0.8.8-SNAPSHOT/asterix-0.8.8-SNAPSHOT.pom.
> Parent=org.apache#apache;LATEST
>
> I had to change the version for org.apache from LATEST to 18-SNAPSHOT.
>
> I found that Maven3 does not support Metaversion as in Maven2
> https://cwiki.apache.org/confluence/display/MAVEN/Maven+3.x+Compatibility+Notes#Maven3.xCompatibilityNotes-PluginMetaversionResolution
>
>
>
> -- 
>
> *Regards,*
> Wail Alkowaileet

Mime
View raw message