asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Maxon <ima...@uci.edu>
Subject Re: Maven 3.1.1 required now
Date Thu, 29 Oct 2015 23:33:27 GMT
Whoops! Sorry about that. I always used 3.1.1 manually installed, the
version in Debian is carbon dated.The build server uses 3.1.1 as well.

On Thu, Oct 29, 2015 at 3:56 PM, Chris Hillery <chillery@hillery.land> wrote:
> Quick note: as of the current AsterixDB tip 6059af3, Maven 3.1.1 is a
> requirement to build.
>
> Unfortunately the newest version of Maven in the current Ubuntu Long-Term
> Support  release (Trusty Tahir, 14.04) is 3.0.5. Linux Mint 17 is derived
> from Ubuntu LTS so it also only has 3.0.5.
>
> You can install Maven manually, of course, but if you want it handled by
> your package manager, it's a little tricky. Here's what I did that worked:
>
> 1. Purge the old version of Maven.
>
>    sudo apt-get purge maven\*
>
> 2. (optional) Remove packages that are possibly now not necessary.
>
>    sudo apt-get --purge autoremove
>
> 3. Add the following PPA:
>
>    sudo add-apt-repository ppa:natecarlson/maven3
>
> 4. The PPA only has packages up through Ubuntu 12.04 (Precise Pangolin),
> but Java packages don't care much. So:
>
>    sudo vi /etc/apt/sources/list.d/natecarlson-maven3-trusty.list
>
> and change "trusty" to "precise" on line 1 and 2.
>
> 5. Install Maven 3:
>
>    sudo apt-get update
>    sudo apt-get install maven3
>
> 6. (optional) The binary in this package named "mvn3", so alias "mvn" to
> that or create a symlink on your PATH or whatever.
>
> Ceej
> aka Chris Hillery

Mime
View raw message