asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aidan Macdonald <aidan.plenert.macdon...@gmail.com>
Subject Re: Code is using Hostname and /etc/hosts
Date Wed, 28 Oct 2015 01:16:23 GMT
Sorry, I hit send too early.

/etc/hosts was actually

10.17.16.49   master

10.17.16.61   slave


Checking the logs on the slave

java.rmi.ConnectException: Connection refused to host: 10.17.16.49; nested
exception is:
        java.net.ConnectException: Connection refused
        at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:619)
        at
sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:216)

Correcting /etc/hosts as

10.17.16.71   master
10.17.16.61   slave


fixed it,

$ bin/managix stop -n test && bin/managix start -n test
INFO: Stopped Asterix instance: test
INFO: Name:test
Created:Tue Oct 27 17:16:58 PDT 2015
Web-Url:http://127.0.0.1:19001
State:ACTIVE (Tue Oct 27 18:14:56 PDT 2015)





Aidan Plenert Macdonald
Website <http://acsweb.ucsd.edu/~amacdona/>

On Tue, Oct 27, 2015 at 6:08 PM, Aidan Macdonald <
aidan.plenert.macdonald@gmail.com> wrote:

> Hi,
>
> I am not sure if this is a bug or a feature, but it certainly caught me
> unaware.
>
> I had a system where the IP attached to my hostname in /etc/hosts was old
> (because of poor system administration ... my fault)
>
> 10.16.17.49   master
> 10.17.16.61
>
>
> Trying to start an Asterix instance with this as master gave,
>
> $ bin/managix start -n test
> INFO: Name:test
> Created:Tue Oct 27 17:16:58 PDT 2015
> Web-Url:http://127.0.0.1:19001
> State:ACTIVE (Tue Oct 27 17:59:25 PDT 2015)
>
> WARNING!:Node Controller not running at the following nodes
> 10.17.16.61
>
>
>
>
> Aidan Plenert Macdonald
> Website <http://acsweb.ucsd.edu/~amacdona/>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message