arrow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Cutler <cutl...@gmail.com>
Subject Re: [VOTE] Release Apache Arrow 0.15.1 - RC0
Date Fri, 01 Nov 2019 04:43:41 GMT
After changing it to `pip install archery` it will use my base conda env.
Then I get an error that `archery integration` is not a valid command:

+ INTEGRATION_TEST_ARGS=
+ '[' OFF = ON ']'
+
LD_LIBRARY_PATH=/tmp/arrow-0.15.1.0tRNC/apache-arrow-0.15.1/cpp/build/release:/tmp/arrow-0.15.1.0tRNC/install/lib:
+ archery integration --with-cpp=1 --with-java=1 --with-js=0 --with-go=0
Usage: archery [OPTIONS] COMMAND [ARGS]...
Try "archery --help" for help.

Error: No such command "integration".

Checking the install, it only has 2 options to benchmark or build:
$ archery --help
Usage: archery [OPTIONS] COMMAND [ARGS]...

  Apache Arrow developer utilities.

  See sub-commands help with `archery <cmd> --help`.

Options:
  --debug      Increase logging with debugging output.
  --pdb        Invoke pdb on uncaught exception.
  -q, --quiet  Silence executed commands.
  --help       Show this message and exit.

Commands:
  benchmark  Arrow benchmarking.
  build      Initialize an Arrow C++ build

On Thu, Oct 31, 2019 at 2:38 PM Bryan Cutler <cutlerb@gmail.com> wrote:

> I am using a conda env, so that will install the package there. When
> archery runs the integration tests though, it looks like it uses my system
> python/pip3, which doesn't have any of the required packages. Not sure if
> I'm missing something to use the right environment.
>
> On Thu, Oct 31, 2019 at 2:17 PM Wes McKinney <wesmckinn@gmail.com> wrote:
>
>> hi Bryan -- I think `pip3 install setuptools` will take care of it
>>
>> On Thu, Oct 31, 2019 at 2:06 PM Bryan Cutler <cutlerb@gmail.com> wrote:
>> >
>> > +1 (non-binding), although I could not complete the source verification
>> > script
>> >
>> > On Ubuntu 16.04 I ran
>> >  * verification script for binaries, no issues
>> >  * verification script for source, could not complete:
>> > TEST_DEFAULT=0 TEST_SOURCE=1 TEST_PYTHON=1 TEST_INTEGRATION_CPP=1
>> > TEST_INTEGRATION_JAVA=1 ARROW_FLIGHT=OFF
>> > dev/release/verify-release-candidate.sh source 0.15.1 0
>> > I had an issue building ORC adapter, and had to manually disable.
>> Probably
>> > an env issue for me.
>> > I ran into the following problem, I think this is due to using my system
>> > python instead of the active conda env, possibly caused by changes in
>> > https://github.com/apache/arrow/pull/5600
>> > + pip3 install -e dev/archery
>> > Obtaining file:///tmp/arrow-0.15.1.7OxLD/apache-arrow-0.15.1/dev/archery
>> >     Complete output from command python setup.py egg_info:
>> >     Traceback (most recent call last):
>> >       File "<string>", line 1, in <module>
>> >     ImportError: No module named 'setuptools'
>> >
>> > Any way to get around this?
>> >
>> > On Thu, Oct 31, 2019 at 6:53 AM Francois Saint-Jacques <
>> > fsaintjacques@gmail.com> wrote:
>> >
>> > > +1 (non-binding)
>> > >
>> > > Ubuntu 18.04
>> > > - Source release verified
>> > > - Binary release verified
>> > >
>> > > François
>> > >
>> > >
>> > > On Fri, Oct 25, 2019 at 2:43 PM Krisztián Szűcs
>> > > <szucs.krisztian@gmail.com> wrote:
>> > > >
>> > > > Hi,
>> > > >
>> > > > I would like to propose the following release candidate (RC0) of
>> Apache
>> > > > Arrow version 0.15.1. This is a patch release consisting of 36
>> resolved
>> > > > JIRA issues[1].
>> > > >
>> > > > This release candidate is based on commit:
>> > > > b789226ccb2124285792107c758bb3b40b3d082a [2]
>> > > >
>> > > > The source release rc0 is hosted at [3].
>> > > > The binary artifacts are hosted at [4][5][6][7].
>> > > > The changelog is located at [8].
>> > > >
>> > > > Please download, verify checksums and signatures, run the unit
>> tests,
>> > > > and vote on the release. See [9] for how to validate a release
>> candidate.
>> > > >
>> > > > The vote will be open for at least 72 hours.
>> > > >
>> > > > [ ] +1 Release this as Apache Arrow 0.15.1
>> > > > [ ] +0
>> > > > [ ] -1 Do not release this as Apache Arrow 0.15.1 because...
>> > > >
>> > > > [1]:
>> > >
>> https://issues.apache.org/jira/issues/?jql=project%20%3D%20ARROW%20AND%20status%20in%20%28Resolved%2C%20Closed%29%20AND%20fixVersion%20%3D%200.15.1
>> > > > [2]:
>> > >
>> https://github.com/apache/arrow/tree/b789226ccb2124285792107c758bb3b40b3d082a
>> > > > [3]:
>> > > https://dist.apache.org/repos/dist/dev/arrow/apache-arrow-0.15.1-rc0
>> > > > [4]: https://bintray.com/apache/arrow/centos-rc/0.15.1-rc0
>> > > > [5]: https://bintray.com/apache/arrow/debian-rc/0.15.1-rc0
>> > > > [6]: https://bintray.com/apache/arrow/python-rc/0.15.1-rc0
>> > > > [7]: https://bintray.com/apache/arrow/ubuntu-rc/0.15.1-rc0
>> > > > [8]:
>> > >
>> https://github.com/apache/arrow/blob/b789226ccb2124285792107c758bb3b40b3d082a/CHANGELOG.md
>> > > > [9]:
>> > >
>> https://cwiki.apache.org/confluence/display/ARROW/How+to+Verify+Release+Candidates
>> > >
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message