arrow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacques Nadeau <jacq...@apache.org>
Subject Re: FlightGetInfo or FlightInfo
Date Tue, 02 Apr 2019 14:49:18 GMT
FlightInfo sgtm



On Tue, Apr 2, 2019 at 7:14 AM Wes McKinney <wesmckinn@gmail.com> wrote:

> I don't have a problem with the name personally but writing a patch
> would be the next step.
>
> On Tue, Apr 2, 2019 at 8:59 AM ming zhang <ming.zhang.china@gmail.com>
> wrote:
> >
> > looks like we are ok with FlighInfo. what is the next step? should I
> write
> > a proposal or submit a patch? i just start working around Arrow Flight
> and
> > need to learn the procedure here. thanks
> >
> >
> >
> >
> > On Tue, Apr 2, 2019 at 9:48 AM Antoine Pitrou <antoine@python.org>
> wrote:
> >
> > >
> > > Oh, you're right.  The corresponding method is already named
> GetFlightInfo.
> > >
> > > Regards
> > >
> > > Antoine.
> > >
> > >
> > > Le 02/04/2019 à 15:37, Wes McKinney a écrit :
> > > > FlightGetInfo is a message so if we are going to change the name, we
> > > > should make it more noun-like, such as FlightInfo.
> > > >
> > > > On Tue, Apr 2, 2019 at 7:08 AM Antoine Pitrou <antoine@python.org>
> > > wrote:
> > > >>
> > > >>
> > > >> If we change it, I vote for GetFlightInfo.
> > > >>
> > > >> Regards
> > > >>
> > > >> Antoine.
> > > >>
> > > >>
> > > >> Le 02/04/2019 à 14:07, ming zhang a écrit :
> > > >>> Hi
> > > >>>
> > > >>> The name of FlightGetInfo is kind of strange. It is a
> noun+verb+noun,
> > > which
> > > >>> is not consistent with others like FlightData, FlightDescriptor,
> etc.
> > > The
> > > >>> 1st impression is that this is a method, not a message, since
other
> > > methods
> > > >>> are verb+noun.
> > > >>>
> > > >>> Should FlightGetInfo to be FlightInfo?
> > > >>>
> > > >>> Thanks
> > > >>> Ming
> > > >>>
> > >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message