arrow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kouhei Sutou <...@clear-code.com>
Subject Re: [VOTE] Release Apache Arrow 0.13.0 - RC3
Date Wed, 27 Mar 2019 20:38:28 GMT
Hi,

> However, source verification failed with the following messages during
> the C++ build:
> 
> CMake Error at
> /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137
> (message):
>   Could NOT find DoubleConversion (missing: DoubleConversion_LIB
>   DoubleConversion_INCLUDE_DIR)
> Call Stack (most recent call first):
>   /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378
> (_FPHSA_FAILURE_MESSAGE)
>   cmake_modules/FindDoubleConversion.cmake:35
> (find_package_handle_standard_args)
>   cmake_modules/ThirdpartyToolchain.cmake:507 (find_package)
>   CMakeLists.txt:544 (include)

This is caused by the default value of
ARROW_DEPENDENCY_SOURCE. If CONDA_PREFIX environment
variable is defined, we use "CONDA" as the default value:
https://github.com/apache/arrow/blob/master/cpp/CMakeLists.txt#L209-L211

But we don't install dependencies to the conda environment
in the verification script. So the default value isn't
suitable in the verification script. We should specify
-DARROW_DEPENDENCY_SOURCE=AUTO explicitly.

I'll send a pull request for this.

Thanks,
--
kou

In <6855afdd-2c85-42ab-1aa7-ae819d6ed839@python.org>
  "Re: [VOTE] Release Apache Arrow 0.13.0 - RC3" on Wed, 27 Mar 2019 14:55:30 +0100,
  Antoine Pitrou <antoine@python.org> wrote:

> 
> Hi,
> 
> Le 27/03/2019 à 12:36, Kouhei Sutou a écrit :
>> Hi,
>> 
>> I would like to propose the following release candidate (RC3) of Apache
>> Arrow version 0.13.0. This is a release consiting of 584
>> resolved JIRA issues[1].
>> 
>> This release candidate is based on commit:
>> 6de758a9e5f74d50ec3458b2af17b7d2d892c573 [2]
>> 
>> The source release rc3 is hosted at [3].
>> The binary artifacts are hosted at [4][5][6][7].
>> The changelog is located at [8].
>> 
>> Please download, verify checksums and signatures, run the unit tests,
>> and vote on the release. See [9] for how to validate a release candidate.
> 
> I verified the binaries on Ubuntu 18.04 (x86-64).
> 
> However, source verification failed with the following messages during
> the C++ build:
> 
> CMake Error at
> /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137
> (message):
>   Could NOT find DoubleConversion (missing: DoubleConversion_LIB
>   DoubleConversion_INCLUDE_DIR)
> Call Stack (most recent call first):
>   /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378
> (_FPHSA_FAILURE_MESSAGE)
>   cmake_modules/FindDoubleConversion.cmake:35
> (find_package_handle_standard_args)
>   cmake_modules/ThirdpartyToolchain.cmake:507 (find_package)
>   CMakeLists.txt:544 (include)
> 
> 
> Regards
> 
> Antoine.
Mime
View raw message