arrow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chase Slater (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (ARROW-516) Building pyarrow with parquet
Date Fri, 27 Jan 2017 16:28:24 GMT

     [ https://issues.apache.org/jira/browse/ARROW-516?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chase Slater closed ARROW-516.
------------------------------
    Resolution: Fixed

> Building pyarrow with parquet
> -----------------------------
>
>                 Key: ARROW-516
>                 URL: https://issues.apache.org/jira/browse/ARROW-516
>             Project: Apache Arrow
>          Issue Type: Bug
>          Components: Python
>         Environment: Debian 8 running inside docker hosted on Ubuntu 16.04
>            Reporter: Chase Slater
>            Priority: Trivial
>              Labels: beginner, build
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> I'm so close to getting pyarrow installed but I'm getting this error when building extensions:
> {code}
> python setup.py build_ext --with-parquet --build-type=release install
> ...
> Using ld linker
> -- Searching for Python libs in /opt/conda/lib64;/opt/conda/lib;/opt/conda/lib/python3.5/config-3.5m
> -- Looking for python3.5m
> -- Found Python lib /opt/conda/lib/libpython3.5m.so
> -- Searching for Python libs in /opt/conda/lib64;/opt/conda/lib;/opt/conda/lib/python3.5/config-3.5m
> -- Looking for python3.5m
> -- Found Python lib /opt/conda/lib/libpython3.5m.so
> -- Found the Parquet library: /usr/local/lib/libparquet.so
> -- Found the Arrow core library: /usr/local/lib/libarrow.so
> -- Found the Arrow IO library: /usr/local/lib/libarrow_io.so
> -- Found the Arrow IPC library: /usr/local/lib/libarrow_ipc.so
> -- Added shared library dependency arrow: /usr/local/lib/libarrow.so
> -- Added shared library dependency arrow_io: /usr/local/lib/libarrow_io.so
> -- Added shared library dependency arrow_ipc: /usr/local/lib/libarrow_ipc.so
> -- Added shared library dependency python: /opt/conda/lib/libpython3.5m.so
> CMake Error at CMakeLists.txt:434 (message):
>   Unable to locate Parquet libraries
> -- Configuring incomplete, errors occurred!
> See also "/tmp/arrow/python/build/temp.linux-x86_64-3.5/CMakeFiles/CMakeOutput.log".
> See also "/tmp/arrow/python/build/temp.linux-x86_64-3.5/CMakeFiles/CMakeError.log".
> error: command 'cmake' failed with exit status 1
> {code}
> I'm not sure how to proceed since it finds the parquet library prior to raising an error
that it cant find it.   Any suggestions or is there other information I need to provide?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message