arrow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From u..@apache.org
Subject arrow git commit: ARROW-1124: Increase numpy dependency to >=1.10.x
Date Sat, 17 Jun 2017 17:27:13 GMT
Repository: arrow
Updated Branches:
  refs/heads/master d54bf4829 -> 1a23419fb


ARROW-1124: Increase numpy dependency to >=1.10.x

While we could still build with NumPy>=1.9 for Python 2, Python 3 builds
require >= 1.10 due to a bug in the C-headers.

Change-Id: I0f9e0ad72e4ce4b1c6b44883d5781347d33f7e5b

Author: Uwe L. Korn <uwelk@xhochy.com>

Closes #758 from xhochy/ARROW-1124 and squashes the following commits:

5fff1ea [Uwe L. Korn] ARROW-1124: Increase numpy dependency to >=1.10.x


Project: http://git-wip-us.apache.org/repos/asf/arrow/repo
Commit: http://git-wip-us.apache.org/repos/asf/arrow/commit/1a23419f
Tree: http://git-wip-us.apache.org/repos/asf/arrow/tree/1a23419f
Diff: http://git-wip-us.apache.org/repos/asf/arrow/diff/1a23419f

Branch: refs/heads/master
Commit: 1a23419fb1ec1ead90eb45e4b3c2cacd8a85bba9
Parents: d54bf48
Author: Uwe L. Korn <uwelk@xhochy.com>
Authored: Sat Jun 17 19:27:08 2017 +0200
Committer: Uwe L. Korn <uwelk@xhochy.com>
Committed: Sat Jun 17 19:27:08 2017 +0200

----------------------------------------------------------------------
 python/requirements.txt | 2 +-
 python/setup.py         | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/arrow/blob/1a23419f/python/requirements.txt
----------------------------------------------------------------------
diff --git a/python/requirements.txt b/python/requirements.txt
index f42c90c..103f490 100644
--- a/python/requirements.txt
+++ b/python/requirements.txt
@@ -1,3 +1,3 @@
 pytest
-numpy>=1.7.0
+numpy>=1.10.0
 six

http://git-wip-us.apache.org/repos/asf/arrow/blob/1a23419f/python/setup.py
----------------------------------------------------------------------
diff --git a/python/setup.py b/python/setup.py
index e10b4b8..eddf88a 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -366,7 +366,7 @@ setup(
     },
     use_scm_version={"root": "..", "relative_to": __file__},
     setup_requires=['setuptools_scm', 'cython >= 0.23'],
-    install_requires=['numpy >= 1.9', 'six >= 1.0.0'],
+    install_requires=['numpy >= 1.10', 'six >= 1.0.0'],
     tests_require=['pytest'],
     description="Python library for Apache Arrow",
     long_description=long_description,


Mime
View raw message