aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Ward (JIRA)" <>
Subject [jira] [Commented] (ARIES-1671) Adding a standard JPA extender capability
Date Wed, 25 Jan 2017 22:23:26 GMT


Timothy Ward commented on ARIES-1671:

Also, the extender capability must be taken into account when deciding which bundle(s) to

"The JPA extender must only process a persistence bundle's persistence units if the following
is true:
• The bundle's wiring has a required wire for at least one osgi.extender capability with
the name osgi.jpa and the first of these required wires is wired to the JPA extender.
• The bundle's wiring has no required wire for an osgi.extender capability with the name

Otherwise, the JPA Service extender must not process the persistence bundle"

> Adding a standard JPA extender capability
> -----------------------------------------
>                 Key: ARIES-1671
>                 URL:
>             Project: Aries
>          Issue Type: Bug
>          Components: JPA
>    Affects Versions: jpa-2.6.0
>            Reporter: Timothy Ward
> OSGi JPA Service 1.1 compatibility
> The JPA Service extender is required to advertise the following:
> Provide-Capability: osgi.extender;
>     osgi.extender="osgi.jpa";
>     version:Version="1.1";
>     uses:="org.osgi.service.jpa,javax.persistence"

This message was sent by Atlassian JIRA

View raw message