aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bas (JIRA)" <>
Subject [jira] [Commented] (ARIES-1444) Subsystem does not install because feature subsystem exports all constituents
Date Fri, 19 Feb 2016 09:02:18 GMT


Bas commented on ARIES-1444:

I will try to reproduce this one with new builds of subsystem.
I also updated our karaf runtime with a new equinox build (3.10.100) which is a lot higher
than what is delivered with a standard karaf 4 build. (karaf 4 uses 3.10.2 which was used
when we encountered the problem described above) I'm hoping this might also make a difference
for this case because I think the resolver is packaged in this equinox bundle. 

> Subsystem does not install because feature subsystem exports all constituents
> -----------------------------------------------------------------------------
>                 Key: ARIES-1444
>                 URL:
>             Project: Aries
>          Issue Type: Bug
>          Components: Subsystem
>    Affects Versions: subsystem-2.0.6, subsystem-2.0.8
>         Environment: karaf
>            Reporter: Bas
>            Assignee: John Ross
> The resolver will try endlessly to resolve the situation presented to it. You do have
to restart the subsystem core bundle before this happens because after that the feature exports
all constituent capabilities.
> While debugging it shows the following messages: 
> org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve
resource nl.capesystemsintegration.testcu.bus.testms.container-infra [org.apache.aries.subsystem.core.internal.BasicSubsystem@73ed4f]
because it exports package 'net.sf.saxon.sxpath' and is also exposed to it from resource org.apache.servicemix.bundles.saxon
[osgi.identity; osgi.identity="org.apache.servicemix.bundles.saxon"; type="osgi.bundle"; version:Version=""]
via the following dependency chain:
>   nl.capesystemsintegration.testcu.bus.testms.container-infra [org.apache.aries.subsystem.core.internal.BasicSubsystem@73ed4f]
>     import: (&(osgi.wiring.package=net.sf.saxon.trans)(&(version>=9.4.0)(!(version>=10.0.0))))
>      |
>     export: osgi.wiring.package: net.sf.saxon.trans; uses:=net.sf.saxon.sxpath
>     export: osgi.wiring.package=net.sf.saxon.sxpath
>   org.apache.servicemix.bundles.saxon [osgi.identity; osgi.identity="org.apache.servicemix.bundles.saxon";
type="osgi.bundle"; version:Version=""]

This message was sent by Atlassian JIRA

View raw message