aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Ross (JIRA)" <>
Subject [jira] [Created] (ARIES-1427) org.osgi.service.subsystem.SubsystemException: java.lang.IllegalArgumentException: Invalid filter: (version=*)
Date Tue, 06 Oct 2015 17:45:26 GMT
John Ross created ARIES-1427:

             Summary: org.osgi.service.subsystem.SubsystemException: java.lang.IllegalArgumentException:
Invalid filter: (version=*)
                 Key: ARIES-1427
             Project: Aries
          Issue Type: Bug
          Components: Subsystem
    Affects Versions: subsystem-2.0.4
            Reporter: John Ross
            Assignee: John Ross
             Fix For: subsystem-2.0.6

An exception can occur when converting an osgi.wiring.package requirement into an Import-Package
header [1]. This can only occur with an open ended version range. For example, (1.5, 2.0).
This range is converted into the following filter form: (&(version=*)(!(version<=1.5.0))(!(version>=2.0.0))).
The presence operator is required because the filter would otherwise match when a version
attribute was not specified.

Caused by: java.lang.IllegalArgumentException: Invalid filter: (version=*)
	at org.apache.aries.subsystem.core.archive.AbstractClauseBasedHeader.parseVersionRange(
	at org.apache.aries.subsystem.core.archive.ImportPackageHeader$Clause.valueOf(
	at org.apache.aries.subsystem.core.internal.RawSubsystemResource.computeImportPackageHeader(
	at org.apache.aries.subsystem.core.internal.RawSubsystemResource.addImportPackageHeader(
	at org.apache.aries.subsystem.core.internal.RawSubsystemResource.computeSubsystemManifestAfterRequirements(
	at org.apache.aries.subsystem.core.internal.RawSubsystemResource.<init>(
	at org.apache.aries.subsystem.core.internal.SubsystemResource.<init>(
	... 15 more

This message was sent by Atlassian JIRA

View raw message