aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Ross (JIRA)" <>
Subject [jira] [Updated] (ARIES-1328) Application subsystem does not import services
Date Thu, 24 Sep 2015 00:43:05 GMT


John Ross updated ARIES-1328:
    Attachment:     (was: require-capability-service-2.patch)

> Application subsystem does not import services
> ----------------------------------------------
>                 Key: ARIES-1328
>                 URL:
>             Project: Aries
>          Issue Type: Bug
>          Components: Subsystem
>    Affects Versions: subsystem-core-1.2.0
>            Reporter: David Bosschaert
>            Assignee: David Bosschaert
>         Attachments: api-bundle-1.0.0-SNAPSHOT.jar, application-subsystem-nosvc-1.0.0-SNAPSHOT.esa,
application-subsystem-nosvc-rc.esa, application-subsystem-nosvc-ubrc.esa, svc-bundle2-1.0.0-SNAPSHOT.jar,
> I have an application Subsystem that has a bundle that looks for a service via a service
> This service and its API is provided by pre-existing bundles (api-bundle, svc-bundle2)
in the parent subsystem. 
> The OSGi enterprise R5 spec states in 134.16.1 (Application Subsystems):
> "Any required capabilities that are not satisfied by the application's constituents are
automatically shared in (imported) from the parent Subsystem."
> However when I install and start the application subsystem (application-subsystem-nosvc),
it does not find the services provided in the parent.
> I'm attaching the bundles and subsystem to reproduce. The full source code can be found

This message was sent by Atlassian JIRA

View raw message