aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Bosschaert <>
Subject Re: versioning plugin release for Maven 3.1+
Date Mon, 12 May 2014 19:14:22 GMT
FWIW - I still do most of my work on Maven 3.0.5 as some of the
projects I work on don't work with 3.1. They might work with 3.2 but I
haven't tried that yet.

One other thing to mention is that an extension is being proposed to
the maven-bundle-plugin that supports semantic versioning. That
implementation is using the bnd baselining under the hood, which
supports semantic versioning a little better than the Aries versioning
plugin AFAIK...
See here:

Best regards,


On 12 May 2014 20:59, Daniel Kulp <> wrote:
> I just updated the versioning plugin to use the org.eclipse version of Aether.   This
allows it to work with Maven 3.1+, but means it won’t work with Maven 3.0.x.   We could
do a lot more work to get it working for both, but I’m not sure it’s worth it.
> Would folks be OK with me doing a release of the plugin for Maven 3.1+ and start updating
the various poms to use that version?   I hate having to drop to the older Maven just for
> --
> Daniel Kulp
> -
> Talend Community Coder -

View raw message