aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tang Yong <>
Subject [Asking]About an import issue of org.apache.aries.application
Date Mon, 15 Apr 2013 14:46:37 GMT

I met an issue while using Aries application and blueprint as following:

[2013-04-15T23:41:57.203+0900] [glassfish 4.0] [SEVERE] [] [] [tid:
_ThreadID=12 _ThreadName=Thread-4] [timeMillis: 1366036917203]
[levelValue: 1000] [[
  org.osgi.framework.BundleException: Unresolved constraint in bundle
org.apache.aries.application [300]: Unable to resolve 300.0: missing
requirement [300.0] osgi.wiring.package;
	at org.apache.felix.framework.Felix.resolveBundleRevision(
	at org.apache.felix.framework.Felix.startBundle(
	at org.apache.felix.framework.Felix.setActiveStartLevel(

I have investigated the above issue and have the following initial result:

org.apache.aries.application has an importing for org.apach
 e.aries.blueprint.ext.impl;version="[1.0,2)", however,
org.apache.aries.blueprint.core does not export
"org.apache.aries.blueprint.ext.impl", so, I want to know whether here
having some issue?


View raw message