aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Holly Cummins <holly.k.cumm...@googlemail.com>
Subject Re: Subsystems proxy dependency version
Date Sat, 01 Sep 2012 09:54:20 GMT
Actually, further to this, I've just done a bit more looking, and
there are a few sub-1.0.0 dependencies in the subsystem code which
will need to be moved to the 1.0.0 versions before the subsystems
bundles will be able to work with the recently released Aries bundles.
They didn't get updated automatically since subsystems weren't hooked
into the build.

This is the list I came up with. The parent dependencies won't affect
the ability of the bundles to resolve, but they do mean that the
subsystem bundles won't be building in quite the same way as
everything else and will miss out on things like bytecode
compatibility checking.

dhcp-9-180-165-6:subsystem holly$ grep -B3 -r \>0..\< * | grep -v .svn
| grep pom.xml
subsystem-api/pom.xml-    <parent>
subsystem-api/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-api/pom.xml-        <artifactId>java6-parent</artifactId>
subsystem-api/pom.xml:        <version>0.4</version>
subsystem-core/pom.xml-    <parent>
subsystem-core/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-core/pom.xml-        <artifactId>java6-parent</artifactId>
subsystem-core/pom.xml:        <version>0.4</version>
subsystem-example/pom.xml-    <parent>
subsystem-example/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-example/pom.xml-        <artifactId>java5-parent</artifactId>
subsystem-example/pom.xml:        <version>0.4</version>
subsystem-example/subsystem-helloIsolation/pom.xml-    <parent>
subsystem-example/subsystem-helloIsolation/pom.xml-
<groupId>org.apache.aries</groupId>
subsystem-example/subsystem-helloIsolation/pom.xml-
<artifactId>java5-parent</artifactId>
subsystem-example/subsystem-helloIsolation/pom.xml:
<version>0.4</version>
subsystem-example/subsystem-helloIsolationRef/pom.xml-    <parent>
subsystem-example/subsystem-helloIsolationRef/pom.xml-
<groupId>org.apache.aries</groupId>
subsystem-example/subsystem-helloIsolationRef/pom.xml-
<artifactId>java5-parent</artifactId>
subsystem-example/subsystem-helloIsolationRef/pom.xml:
<version>0.4</version>
subsystem-executor/pom.xml-    <parent>
subsystem-executor/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-executor/pom.xml-        <artifactId>java5-parent</artifactId>
subsystem-executor/pom.xml:        <version>0.4</version>
subsystem-install/pom.xml-    <parent>
subsystem-install/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-install/pom.xml-        <artifactId>java5-parent</artifactId>
subsystem-install/pom.xml:        <version>0.4</version>
subsystem-itests/pom.xml-    <parent>
subsystem-itests/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-itests/pom.xml-        <artifactId>java6-parent</artifactId>
subsystem-itests/pom.xml:        <version>0.4</version>
subsystem-itests-api-bundle/pom.xml-    <parent>
subsystem-itests-api-bundle/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-itests-api-bundle/pom.xml-
<artifactId>java6-parent</artifactId>
subsystem-itests-api-bundle/pom.xml:        <version>0.4</version>
subsystem-obr/pom.xml-    <parent>
subsystem-obr/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-obr/pom.xml-        <artifactId>java5-parent</artifactId>
subsystem-obr/pom.xml:        <version>0.4</version>
subsystem-scope-api/pom.xml-    <parent>
subsystem-scope-api/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-scope-api/pom.xml-        <artifactId>java5-parent</artifactId>
subsystem-scope-api/pom.xml:        <version>0.4</version>
subsystem-scope-impl/pom.xml-    <parent>
subsystem-scope-impl/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-scope-impl/pom.xml-        <artifactId>java5-parent</artifactId>
subsystem-scope-impl/pom.xml:        <version>0.4</version>
subsystem-scope-impl/pom.xml-        <dependency>
subsystem-scope-impl/pom.xml-
<groupId>org.apache.aries.application</groupId>
subsystem-scope-impl/pom.xml-
<artifactId>org.apache.aries.application.api</artifactId>
subsystem-scope-impl/pom.xml:            <version>0.3</version>
subsystem-scope-impl/pom.xml-        <dependency>
subsystem-scope-impl/pom.xml-
<groupId>org.apache.aries.application</groupId>
subsystem-scope-impl/pom.xml-
<artifactId>org.apache.aries.application.utils</artifactId>
subsystem-scope-impl/pom.xml:            <version>0.3</version>
subsystem-scope-impl/pom.xml-        <dependency>
subsystem-scope-impl/pom.xml-
<groupId>org.apache.aries.testsupport</groupId>
subsystem-scope-impl/pom.xml-
<artifactId>org.apache.aries.testsupport.unit</artifactId>
subsystem-scope-impl/pom.xml:            <version>0.3</version>
subsystem-scope-itests/pom.xml-    <parent>
subsystem-scope-itests/pom.xml-        <groupId>org.apache.aries</groupId>
subsystem-scope-itests/pom.xml-        <artifactId>java5-parent</artifactId>
subsystem-scope-itests/pom.xml:        <version>0.4</version>
subsystem-scope-itests/pom.xml-
<groupId>org.apache.aries.testsupport</groupId>
subsystem-scope-itests/pom.xml-
<artifactId>org.apache.aries.testsupport.unit</artifactId>
subsystem-scope-itests/pom.xml-            <scope>test</scope>
subsystem-scope-itests/pom.xml:            <version>0.3</version>
subsystem-scope-itests/pom.xml-            <groupId>org.apache.aries</groupId>
subsystem-scope-itests/pom.xml-
<artifactId>org.apache.aries.util</artifactId>
subsystem-scope-itests/pom.xml-            <scope>test</scope>
subsystem-scope-itests/pom.xml:            <version>0.3</version>
subsystem-scope-itests/pom.xml-
<groupId>org.apache.aries.application</groupId>
subsystem-scope-itests/pom.xml-
<artifactId>org.apache.aries.application.utils</artifactId>
subsystem-scope-itests/pom.xml-            <scope>test</scope>
subsystem-scope-itests/pom.xml:            <version>0.3</version>


On Sat, Sep 1, 2012 at 10:45 AM, Holly Cummins
<holly.k.cummins@googlemail.com> wrote:
> When I was looking at the builds, I noticed that the subsystem itests
> depend on proxy-1.0.1-SNAPSHOT, rather than proxy-1.0.0. Is there
> something in the 1.0.1 proxy which the subsystem tests need, John? If
> not it would be better to depend on the released version of the proxy
> bundle, 1.0.0. This avoids us having to do a new release of the proxy
> bundle before we can do any subsystem releasing.
>
> (The subsystem tests will run against the 1.0.1 proxy bundle in the
> AriesWithSnapshotDependencies build, anyway.)
>
> Holly

Mime
View raw message