aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Holly Cummins <>
Subject JMX package import versions
Date Fri, 20 Jul 2012 12:31:25 GMT
I've added version ranges to the JMX package imports. The version of
the org.osgi.jmx.framework package, which we implement, changed from
1.5 to 1.7 between r4.2 and r5 of the enterprise spec. This means
version 1.0.0 of our jmx-bundle won't resolve against r5 enterprise
APIs. Is this what you expected, David?

I guess this is why we've got a jmx-next. :)

(All of the other org.osgi.jmx.* packages either stayed unchanged, or
changed but we don't implement them.)


View raw message