aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Holly Cummins <>
Subject Re: proxy-api needs at least org.osgi.framework 1.6.0
Date Fri, 25 May 2012 13:47:21 GMT
On Fri, May 25, 2012 at 2:09 PM, Bal√°zs Zsoldos
<> wrote:
> Hi,
> as I look at it org.apache.aries.proxy.api needs at least
> org.osgi.framework 1.6 which is part of OSGI 4.3. Is it knowingly changed?
> Based on this proxy will not work with older OSGI containers (e.g.
> glassfish till version 3.1.1).

I was wondering about this as well. It doesn't seem ideal, does it?
> This problem may occurs at other places as well where the osgi.core
> dependency was changed to 4.3.

It looks like the proxy changes were made as part of ARIES-826. I
think the original intention of the weaving code was that it would
still be compatible with OSGi 4.2. I guess our options are to do
something like what we've done with util-42, or split off an optional
advanced.api bundle with the 4.3-dependent classes.


View raw message