aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Ross (JIRA)" <>
Subject [jira] [Commented] (ARIES-640) application.utils imports aries.util version [0.4,1.0) but aries.util exports version 0.3.1
Date Tue, 03 May 2011 14:21:10 GMT


John Ross commented on ARIES-640:

While continuing to troubleshoot this, I noticed that running "mvn clean install" from the
blueprint directory failed due to 

[ERROR] Failed to execute goal on project org.apache.aries.blueprint: Could not resolve dependencies
for project org.apache.aries.blueprint:org.apache
.aries.blueprint:bundle:0.3.2-SNAPSHOT: Failure to find org.apache.aries.proxy:org.apache.aries.proxy:jar:0.3.1-SNAPSHOT
in http://snapshots.repositor was cached in the local repository, resolution will not be reattempted until
the update interval of codehaus.snapshots has elapsed or u
pdates are forced -> [Help 1]

Executing "mvn clean install" from the proxy directory succeeded, but it does not create a
jar under the 0.3.1-SNAPSHOT directory. Instead, it creates a jar under the 0.4-SNAPSHOT directory.

Changing the pom.xml within the blueprint directory to 


allows the blueprint install to complete successfully.

> application.utils imports aries.util version [0.4,1.0) but aries.util exports version
> -------------------------------------------------------------------------------------------
>                 Key: ARIES-640
>                 URL:
>             Project: Aries
>          Issue Type: Bug
>          Components: Application
>    Affects Versions: 0.4
>            Reporter: John Ross
> Given the latest repo contents, I encounter the following error when executing some junit
> org.osgi.framework.BundleException: The bundle "org.apache.aries.application.utils_0.4.0.SNAPSHOT
[13]" could not be resolved. Reason: Missing Constraint: Import-Package: org.apache.aries.util;
> 	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(
> 	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(
> 	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(
> 	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(
> 	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(
> 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(
> 	at org.eclipse.osgi.framework.eventmgr.EventManager$
> The manifest within org.apache.aries.application.utils-0.4-SNAPSHOT.jar imports org.apache.aries.util;version="[0.4,1.0)"
but org.apache.aries.util-0.4-SNAPSHOT.jar exports org.apache.aries.util;version="0.3.1".
I've tried "mvn clean install" on those two projects as well as just about everything else.
Am I missing something?

This message is automatically generated by JIRA.
For more information on JIRA, see:

View raw message