aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alasdair Nottingham <>
Subject [DISCUSSION] Using packageinfo to set package versions
Date Fri, 04 Feb 2011 21:33:44 GMT

Currently we specify versions of exported packages in the pom. This is
not ideal as it means whenever anyone makes a change in a package they
have to edit the pom, also you need to sync the version correctly
between the bundles and the uber bundles.

bnd supports the packageinfo files (and also annotations in, but those are not currently picked up and used in
our build. I raise FELIX-2819 and a workaround has been suggested,
which I managed to get working.

The fix would be to add the following to the default-pom and get the
modules to use the updated parent:



Alasdair Nottingham

View raw message