aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (JIRA)" <>
Subject [jira] Commented: (ARIES-582) Updates to the util module required for a 1.0 release
Date Mon, 21 Feb 2011 15:33:38 GMT


Guillaume Nodet commented on ARIES-582:

One way to avoid having the upgrade the major version would be to move the SingleServiceTracker
class into the tracker package, but add a deprecated class in the old package inheriting from
the new SingleServiceTracker.  That could could be removed only when upgrading to next major

> Updates to the util module required for a 1.0 release
> -----------------------------------------------------
>                 Key: ARIES-582
>                 URL:
>             Project: Aries
>          Issue Type: Bug
>          Components: Util
>            Reporter: Alasdair Nottingham
>            Assignee: Alasdair Nottingham
> This work item covers items that should be performed for a 1.x release of the util module.
> Items include:
> 1. Move the SingleServiceTracker into the org.apache.aries.util.tracker package
> 2. Remove the BundleToClassLoaderAdapter class from org.apache.aries.util
> 3. Look into what, if anything, should be moved from application-util into util.

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message