ariatosca-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ran Ziv (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (ARIA-304) Unable to install apache-ariatosca[ssh] via PyPI
Date Sun, 09 Jul 2017 08:38:02 GMT

     [ https://issues.apache.org/jira/browse/ARIA-304?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ran Ziv resolved ARIA-304.
--------------------------
       Resolution: Duplicate
    Fix Version/s: 0.2.0

> Unable to install apache-ariatosca[ssh] via PyPI
> ------------------------------------------------
>
>                 Key: ARIA-304
>                 URL: https://issues.apache.org/jira/browse/ARIA-304
>             Project: AriaTosca
>          Issue Type: Bug
>    Affects Versions: 0.1.0
>            Reporter: Ran Ziv
>            Assignee: Ran Ziv
>            Priority: Critical
>             Fix For: 0.2.0
>
>
> Attempting to install ARIA's {{ssh}} optional dependency via:
> {{pip install apache-ariatosca[ssh]}}
> will result in an error on a non-Windows machine:
> {{ImportError: No module named _winreg}}
> This is due to a limitation of {{wheel}} with regards to environment-marked dependencies
(which results in an attempt to install a Windows-specific dependency on any platform).
> See related issue ARIA-301.
> This also applies for sdist installations as pip will attempt to create a wheel prior
to installation.
> The workaround for this is to use the {{no-binary}} pip flag, which tells it not to use
{{wheel}} and thereby avoiding the limitation:
> {{pip install apache-ariatosca[ssh] --no-binary apache-ariatosca}}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message