ariatosca-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Baillargeon <steve.baillarg...@ericsson.com>
Subject ARIA install on PC
Date Mon, 14 Aug 2017 19:59:29 GMT
Hi
I am trying to install ARIA on PC.
It appears the install is successful but ARIA is not working as expected.

This is what I have on PC:


  *   Windows 7, 32 bits
  *   pip version 9.0.1
  *   python 2.7.9
  *   setuptools 36.2.7

When I try to install ARIA ( I tried a couple of times), this is what I get:

C:\Users\estebai\Documents\incubator-ariatosca-0.1.1>pip install .
Processing c:\users\estebai\documents\incubator-ariatosca-0.1.1
  Requirement already satisfied (use --upgrade to upgrade): apache-ariatosca==0.1.1 from file:///C:/Users/estebai/Documents/incubator-ariatosca-0.1.1
in c:\python27\lib\site-packages
Requirement already satisfied: requests<2.14.0,>=2.3.0 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: networkx<1.10,>=1.9 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: retrying<1.4.0,>=1.3.0 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: blinker<1.5,>1.3 in c:\python27\lib\site-packages (from
apache-ariatosca==0.1.1)
Requirement already satisfied: jsonpickle<=0.9.4,>0.9.0 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: ruamel.yaml<0.12.0,>=0.11.12 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: Jinja2<2.9,>=2.8 in c:\python27\lib\site-packages (from
apache-ariatosca==0.1.1)
Requirement already satisfied: shortuuid<0.6,>=0.5 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: CacheControl[filecache]<0.13,>=0.11.0 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: clint<0.6,>=0.5.0 in c:\python27\lib\site-packages (from
apache-ariatosca==0.1.1)
Requirement already satisfied: SQLAlchemy<1.2,>=1.1.0 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: wagon==0.6.0 in c:\python27\lib\site-packages (from apache-ariatosca==0.1.1)
Requirement already satisfied: bottle<0.13,>=0.12.0 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Collecting setuptools<36.0.0,>=35.0.0 (from apache-ariatosca==0.1.1)
  Using cached setuptools-35.0.2-py2.py3-none-any.whl
Requirement already satisfied: click<7.0,>=6.0 in c:\python27\lib\site-packages (from
apache-ariatosca==0.1.1)
Requirement already satisfied: colorama<=0.3.9,>=0.3.7 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: PrettyTable<0.8,>=0.7 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: click_didyoumean==0.0.3 in c:\python27\lib\site-packages (from
apache-ariatosca==0.1.1)
Requirement already satisfied: backports.shutil_get_terminal_size==1.0.0 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: logutils==0.3.4.1 in c:\python27\lib\site-packages (from apache-ariatosca==0.1.1)
Requirement already satisfied: psutil<6.0.0,>=5.2.2 in c:\python27\lib\site-packages
(from apache-ariatosca==0.1.1)
Requirement already satisfied: decorator>=3.4.0 in c:\python27\lib\site-packages (from
networkx<1.10,>=1.9->apache-ariatosca==0.1.1)
Requirement already satisfied: six>=1.7.0 in c:\python27\lib\site-packages (from retrying<1.4.0,>=1.3.0->apache-ariatosca==0.1.1)
Requirement already satisfied: ruamel.ordereddict in c:\python27\lib\site-packages (from ruamel.yaml<0.12.0,>=0.11.12->apache-ariatosca==0.1.1)
Requirement already satisfied: MarkupSafe in c:\python27\lib\site-packages (from Jinja2<2.9,>=2.8->apache-ariatosca==0.1.1)
Requirement already satisfied: msgpack-python in c:\python27\lib\site-packages (from CacheControl[filecache]<0.13,>=0.11.0->apache-ariatosca==0.1.1)
Requirement already satisfied: lockfile>=0.9 in c:\python27\lib\site-packages (from CacheControl[filecache]<0.13,>=0.11.0->apache-ariatosca==0.1.1)
Requirement already satisfied: args in c:\python27\lib\site-packages (from clint<0.6,>=0.5.0->apache-ariatosca==0.1.1)
Requirement already satisfied: wheel>=0.24.0 in c:\python27\lib\site-packages (from wagon==0.6.0->apache-ariatosca==0.1.1)
Requirement already satisfied: packaging>=16.8 in c:\python27\lib\site-packages (from setuptools<36.0.0,>=35.0.0->apache-ariatosca==0.1.1)
Requirement already satisfied: appdirs>=1.4.0 in c:\python27\lib\site-packages (from setuptools<36.0.0,>=35.0.0->apache-ariatosca==0.1.1)
Requirement already satisfied: pyparsing in c:\python27\lib\site-packages (from packaging>=16.8->setuptools<36.0.0,>=35.0.0->apache-ariatosca==0.1.1)
Building wheels for collected packages: apache-ariatosca
  Running setup.py bdist_wheel for apache-ariatosca ... done
  Stored in directory: C:\Users\estebai\AppData\Local\pip\Cache\wheels\dd\c4\fc\b0237b1a121736cd985968b1076a4ca596761c4c5970e3d9c9
Successfully built apache-ariatosca
Installing collected packages: setuptools
  Found existing installation: setuptools 36.2.7
    Uninstalling setuptools-36.2.7:
      Successfully uninstalled setuptools-36.2.7
Successfully installed setuptools-35.0.2

However when I type the command aria -version, this is what I get:

C:\Users\estebai\Documents\incubator-ariatosca-0.1.1>aria --version
Traceback (most recent call last):
  File "C:\Python27\Scripts\aria-script.py", line 11, in <module>
    load_entry_point('apache-ariatosca==0.1.1', 'console_scripts', 'aria')()
  File "C:\Python27\lib\site-packages\pkg_resources\__init__.py", line 560, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "C:\Python27\lib\site-packages\pkg_resources\__init__.py", line 2648, in load_entry_point
    return ep.load()
  File "C:\Python27\lib\site-packages\pkg_resources\__init__.py", line 2302, in load
    return self.resolve()
  File "C:\Python27\lib\site-packages\pkg_resources\__init__.py", line 2308, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "C:\Python27\lib\site-packages\aria\__init__.py", line 26, in <module>
    from .orchestrator.decorators import workflow, operation  # pylint: disable=wrong-import-position
  File "C:\Python27\lib\site-packages\aria\orchestrator\__init__.py", line 20, in <module>
    from .decorators import (
  File "C:\Python27\lib\site-packages\aria\orchestrator\decorators.py", line 25, in <module>
    from . import context
  File "C:\Python27\lib\site-packages\aria\orchestrator\context\__init__.py", line 20, in
<module>
    from . import workflow, operation
  File "C:\Python27\lib\site-packages\aria\orchestrator\context\workflow.py", line 23, in
<module>
    from .exceptions import ContextException
  File "C:\Python27\lib\site-packages\aria\orchestrator\context\exceptions.py", line 20, in
<module>
    from ..exceptions import OrchestratorError
  File "C:\Python27\lib\site-packages\aria\orchestrator\exceptions.py", line 20, in <module>
    from ..exceptions import OrchestratorError
  File "C:\Python27\lib\site-packages\aria\exceptions.py", line 20, in <module>
    from ..exceptions import AriaError
ValueError: Attempted relative import beyond toplevel package


Regards
Steve Baillargeon


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message