ariatosca-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DeWayne Filppi <dewa...@cloudify.co>
Subject server create problem
Date Tue, 29 Aug 2017 23:38:53 GMT
Here's the latest issue.  Got through all the networking config in my
template, but the server instance doesn't start.  Not sure if this is an
Openstack plugin issue, or Aria..  From the error message, it appears that
the image id and flavor don't even get into the call.  Note that I had to
explicitly set "openstack_config" in the operation inputs:

23:32:42 | E | nova_plugin.server.create | {u'args': OrderedDict(),
u'openstack_config': {'username': 'dewayne', 'tenant_name':
'dewayne-tenant', 'password': 'xxxxxx', 'auth_url': '
https://rackspace-api.gigaspaces.com:5000/v3'}} | vm_1 Standard.create
failed
        |Traceback (most recent call last):
        |  File
"/home/vagrant/incubator-ariatosca/aria/orchestrator/workflows/executor/process.py",
line 342, in _main
        |    task_func(ctx=ctx, **operation_arguments)
        |  File
"/home/vagrant/venv/lib/python2.7/site-packages/adapters/context_adapter.py",
line 434, in wrapper
        |    ctx.task.retry(str(e), retry_interval=e.retry_after)
        |  File "/usr/lib64/python2.7/contextlib.py", line 36, in __exit__
        |    raise RuntimeError("generator didn't stop after throw()")
        |RuntimeError: generator didn't stop after throw()

The node template:

    vm:
      type: aria.openstack.nodes.Server
      properties:
        image: { get_input: image }
        flavor: { get_input: flavor }
        create_if_missing: true
        resource_id: aria_helloworld_vm
        management_network_name: aria_helloworld_network
      requirements:
        - key_pair: keypair
        - port: port
      interfaces:
        Standard:
          create:
            inputs:
              openstack_config: { get_input: openstack_config }

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message