ariatosca-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen, Wei D" <wei.d.c...@intel.com>
Subject RE: How can I use aria CLI options correctly?
Date Tue, 13 Jun 2017 02:20:05 GMT
Hi Ran,

I am on ubuntu 14.04, 64bit, and the content of /etc/hosts is:
cat /etc/hosts
127.0.1.1       openstack-dev.intel.com openstack-dev
# 127.0.0.1     localhost openstack-dev
# 127.0.1.1     openstack-dev.sh.intel.com      openstack-dev
10.239.159.68   openstack-dev openstack-dev.sh.intel.com

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
#shldeOTCopen005 10.239.48.67
10.239.48.159 ceph-dev.intel.com ceph-dev

Will the demo application download any resource from external network? Since I am behind the
firewall so I am not sure is that matter.



> -----Original Message-----
> From: Ran Ziv [mailto:ran@gigaspaces.com]
> Sent: Monday, June 12, 2017 6:04 PM
> To: dev@ariatosca.incubator.apache.org
> Subject: Re: How can I use aria CLI options correctly?
> 
> Which platform/OS/distro are you on?
> 
> Could you please also post here the content of your /etc/hosts file? I think it
> might be related.
> 
> 
> CLI log is available under ~/.aria/cli.log the execution logs are stored in the
> model storage.
> 
> 
> 
> On Mon, Jun 12, 2017 at 12:53 PM, Chen, Wei D <wei.d.chen@intel.com> wrote:
> 
> > Thanks for your quick reply, I saw the "connection refused" error
> > message after showing the logs for the execution id, Is there any
> > dependency from the "helloworld" that I missed?
> >
> >         |  File
> > "/home/dave/gerrit/incubator-ariatosca/tests/resources/
> > service-templates/tosca-simple-1.0/env/local/lib/
> > python2.7/site-packages/aria/orchestrator/execution_plugin/ctx_proxy/c
> > lient.py",
> > line 41, in _http_request
> >         |    response = opener.open(request, timeout=timeout)
> >         |  File "/usr/lib/python2.7/urllib2.py", line 404, in open
> >         |    response = self._open(req, data)
> >         |  File "/usr/lib/python2.7/urllib2.py", line 422, in _open
> >         |    '_open', req)
> >         |  File "/usr/lib/python2.7/urllib2.py", line 382, in _call_chain
> >         |    result = func(*args)
> >         |  File "/usr/lib/python2.7/urllib2.py", line 1214, in http_open
> >         |    return self.do_open(httplib.HTTPConnection, req)
> >         |  File "/usr/lib/python2.7/urllib2.py", line 1184, in do_open
> >         |    raise URLError(err)
> >         |urllib2.URLError: <urlopen error [Errno 111] Connection
> > refused>
> >
> >
> > BTW, do you know where is log persisted?
> >
> >
> > > -----Original Message-----
> > > From: Maxim Orlov [mailto:maxim@gigaspaces.com]
> > > Sent: Monday, June 12, 2017 2:08 PM
> > > To: dev@ariatosca.incubator.apache.org
> > > Subject: Re: How can I use aria CLI options correctly?
> > >
> > > In order to get a more detailed message, you could use the verbosity
> > flag - "-v".
> > > This flag is supported both for the execution start command and the
> > > logs
> > list
> > > command. What you would want to do at this stage is try and figure
> > > out
> > what
> > > happend with the execution you already ran. In order to do that,
> > > locate
> > your
> > > execution id via "aria executions list", and then use the list logs
> > command "aria
> > > logs list -e <execution_id> -vvv".
> > >
> > > On Mon, Jun 12, 2017, 06:43 Chen, Wei D <wei.d.chen@intel.com> wrote:
> > >
> > > > Hi Ran,
> > > >
> > > > Thank you for your help! Here comes another issue when I run the
> > > > "*aria services create hello-service -t hello* *aria executions
> > > > start install -s hello-service*", the console shows me the below message:
> > > > "
> > > > Starting execution. Press Ctrl+C cancel
> > > > 10:29:43 | I | Starting 'install' workflow execution
> > > > 10:29:51 | I | web_app_1 Standard.configure started...
> > > > 10:29:51 | I | Executing: /tmp/tmpeuRKHt-configure.sh
> > > > 10:29:52 | I | Execution done (exit_code=1):
> > > > /tmp/tmpeuRKHt-configure.sh
> > > > 10:29:52 | E | web_app_1 Standard.configure failed
> > > > 10:30:24 | I | web_app_1 Standard.configure started...
> > > > 10:30:24 | I | Executing: /tmp/tmpvwDbY0-configure.sh
> > > > 10:30:25 | I | Execution done (exit_code=1):
> > > > /tmp/tmpvwDbY0-configure.sh
> > > > 10:30:25 | E | web_app_1 Standard.configure failed"
> > > >
> > > > I have no idea why the configuration is failed, any way to trouble
> > > > shooting the issue or where can I find more detailed error message?
> > > >
> > > > > -----Original Message-----
> > > > > From: Ran Ziv [mailto:ran@gigaspaces.com]
> > > > > Sent: Friday, June 9, 2017 4:42 PM
> > > > > To: dev@ariatosca.incubator.apache.org
> > > > > Subject: Re: How can I use aria CLI options correctly?
> > > > >
> > > > > (I've replied on this same mail two days ago, so I guess there's
> > > > > been
> > > > some sort
> > > > > of a mistake. In any case, I've copy-pasted my reply here as
> > > > > well.)
> > > > >
> > > > > Hi Dave,
> > > > >
> > > > > Unfortunately, the README is currently much outddated. That is
> > > > > why the
> > > > "aria
> > > > > parse" command raises an invalid command error.
> > > > >
> > > > > We're working on updating the quick start guide, and hopefully
> > > > > it'll be
> > > > up to date
> > > > > early next week, although that too isn't going to provide a full
> > > > documentation at
> > > > > this time to ARIA but rather only an introduction.
> > > > > In the meanwhile however, we'll be glad to help over on this
> > > > > mailing
> > > > list.
> > > > >
> > > > >
> > > > > The "parse" command indeed no longer exists; Similar
> > > > > functionality can
> > > > be found
> > > > > under "aria service-templates show", but first one has to use
> > > > > "aria
> > > > service-
> > > > > templates store", like so:
> > > > > *aria service-templates store node-cellar.yaml nodecellar* *aria
> > > > > service- templates show nodecellar -f*
> > > > >
> > > > >
> > > > > To actually run workflows etc., you'd have to first create a
> > > > > service for
> > > > a given
> > > > > service-template, e.g.:
> > > > > *aria service-templates store
> > > > > examples/hello-world/helloworld.yaml
> > > > > hello* *aria services create hello-service -t hello* *aria
> > > > > executions start
> > > > install -s hello-
> > > > > service*
> > > > >
> > > > >
> > > > >
> > > > > hope this helps.
> > > > >
> > > > > On Fri, Jun 9, 2017 at 10:34 AM, Chen, Wei D
> > > > > <wei.d.chen@intel.com>
> > > > wrote:
> > > > >
> > > > > > Dear developers,
> > > > > >
> > > > > > I am currently on ARIA, and is trying to follow the quickstack
> > > > > > guide from this post
> > > > > > (https://github.com/apache/incubator-ariatosca), but I am lost
> > > > > > there since the CLI option mentioned in the guide is supported
> > > > yet.
> > > > > >
> > > > > > It said the below command can create a service instance, but
> > > > > > seems like "parse" is not a valid option.
> > > > > > - aria parse blueprints/tosca/node-cellar/node-cellar.yaml
> > > > > >
> > > > > > This is help manual I can see:
> > > > > > $ aria -h
> > > > > > Usage: aria [OPTIONS] COMMAND [ARGS]...
> > > > > >
> > > > > > ARIA's Command Line Interface
> > > > > >
> > > > > > To activate bash-completion. Run: eval
> > > > > > "$(_ARIA_COMPLETE=source
> > aria)"
> > > > > >
> > > > > > ARIA's working directory resides by default in ~/.aria. To
> > > > > > change it, set the environment variable ARIA_WORKDIR to
> > > > > > something else
> > (e.g.
> > > > /tmp/).
> > > > > >
> > > > > > Options:
> > > > > > -v, --verbose Show verbose output. You can supply this up to
> > > > > > three times (i.e. -vvv) --version Display the version and exit
> > > > > > -h, --help Show this message and exit.
> > > > > >
> > > > > > Commands:
> > > > > > executions Handle workflow executions logs Show logs from
> > > > > > workflow executions node-templates Handle a service template's
> > > > > > node templates nodes Handle a service's nodes plugins Handle
> > > > > > plugins reset Reset ARIA's working directory service-templates
> > > > > > Handle service templates on the manager services Handle
> > > > > > services workflows Handle service workflows
> > > > > >
> > > > > > There is no "parse" option list there. I have also tried the
> > > > > > installation via 'pip' with version 0.1,  and this is what I
> > > > > > can
> > see:
> > > > > > $ aria node-cellar.yaml
> > > > > > Validation issues:
> > > > > >   0: location: aria-1.0
> > > > > >      ReaderNotFoundError: location: aria-1.0
> > > > > >
> > > > > >
> > > > > > So, what the error here means? How can I fix it?
> > > > > >
> > > > > > This is how the imports defined in the "node-cellar.yaml" from
> > > > > > the code base.
> > > > > > imports:
> > > > > >   - types/openstack.yaml
> > > > > >   - types/nodejs.yaml
> > > > > >   - types/mongodb.yaml
> > > > > >   - types/nginx.yaml
> > > > > >   - aria-1.0
> > > > > >
> > > > > > Thank you very much!
> > > > > >
> > > > > > Best Regards,
> > > > > > Dave Chen
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > >
> >
Mime
View raw message