ariatosca-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARIA-215) Refactor plugin-related code from ProcessExecutor into PluginManager
Date Sun, 07 May 2017 14:28:05 GMT

    [ https://issues.apache.org/jira/browse/ARIA-215?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15999862#comment-15999862
] 

ASF subversion and git services commented on ARIA-215:
------------------------------------------------------

Commit 3e1ed14c00ea2c83fafdca8ec0e37817bea1d5e8 in incubator-ariatosca's branch refs/heads/ARIA-215-refactor-plugin-related-code
from [~ran]
[ https://git-wip-us.apache.org/repos/asf?p=incubator-ariatosca.git;h=3e1ed14 ]

ARIA-215 Refactor plugin-related code into PluginManager

Refactored plugin-related code from ProcessExecutor into PluginManager.
Additionally, renamed plugin_prefix to plugin_dir in PluginManager.


> Refactor plugin-related code from ProcessExecutor into PluginManager
> --------------------------------------------------------------------
>
>                 Key: ARIA-215
>                 URL: https://issues.apache.org/jira/browse/ARIA-215
>             Project: AriaTosca
>          Issue Type: Task
>            Reporter: Ran Ziv
>            Assignee: Ran Ziv
>            Priority: Minor
>
> {{ProcessExecutor}} currently handles the code for loading a plugin into an environment
- this code should move into the {{PluginManager}} class instead.
> Additionally, {{PluginManager}}'s {{plugin_prefix}} method should be renamed to {{plugin_dir}}.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message