ariatosca-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARIA-155) Clean models from unused fields
Date Thu, 04 May 2017 14:08:04 GMT

    [ https://issues.apache.org/jira/browse/ARIA-155?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15996774#comment-15996774
] 

ASF subversion and git services commented on ARIA-155:
------------------------------------------------------

Commit d0c5e6fa1732a1b90992a7a75721b408f8a1b575 in incubator-ariatosca's branch refs/heads/ARIA-163-Update-node-state-for-stub-tasks
from [~ran]
[ https://git-wip-us.apache.org/repos/asf?p=incubator-ariatosca.git;h=d0c5e6f ]

ARIA-155 Clean models from unused fields


> Clean models from unused fields
> -------------------------------
>
>                 Key: ARIA-155
>                 URL: https://issues.apache.org/jira/browse/ARIA-155
>             Project: AriaTosca
>          Issue Type: Task
>            Reporter: Ran Ziv
>            Assignee: Ran Ziv
>            Priority: Minor
>             Fix For: 0.1.0
>
>
> Some models have fields which should probably be removed (as they're no longer in use
or haven't been put to use yet) or rename (due to inconsistencies).
> Suggested changes:
> Service changes module:
>  - remove module entirely, until we actually implement scaling / service-update
> Service:
>  - remove {{permalink}}
>  - remove {{scaling_groups}}
> Node:
>  - remove {{scaling_groups}}
> Operation:
>  - rename {{max_retries}} to {{max_attempts}}
> OperationTemplate:
>  - rename {{max_retries}} to {{max_attempts}}
> Execution:
>  - remove {{is_system_workflow}}
> Task:
>  - rename {{retry_count}} to {{attempts_count}}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message