ariatosca-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ran Ziv (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ARIA-155) Clean models from unused fields
Date Thu, 27 Apr 2017 08:07:04 GMT

     [ https://issues.apache.org/jira/browse/ARIA-155?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ran Ziv updated ARIA-155:
-------------------------
    Description: 
Some models have fields which should probably be removed (as they're no longer in use or haven't
been put to use yet) or rename (due to inconsistencies).


Suggested changes:

* Service:
   - remove {{permalink}}
   - remove {{scaling_groups}}
 - remove {{modifications}} and {{updates}}

* Node:
 - remove {{scaling_groups}}

* Relationship:
 - remove {{source_position}}
 - remove {{target_position}}

* Operation:
 - rename {{max_retries}} to {{max_attempts}}
 - remove {{executor}}

* OperationTemplate:
 - remove {{executor}}

* Execution:
 - remove {{is_system_workflow}}

* Task:
 - rename {{retry_count}} to {{attempts_count}}

  was:
Some models have fields which should probably be removed (as they're no longer in use or haven't
been put to use yet) or rename (due to inconsistencies).


Suggested changes:

* Service:
 - remove {{permalink}}
 - remove {{scaling_groups}}
 - remove {{modifications}} and {{updates}}

* Node:
 - remove {{scaling_groups}}

* Relationship:
 - remove {{source_position}}
 - remove {{target_position}}

* Operation:
 - rename {{max_retries}} to {{max_attempts}}
 - remove {{executor}}

* OperationTemplate:
 - remove {{executor}}

* Execution:
 - remove {{is_system_workflow}}

* Task:
 - rename {{retry_count}} to {{attempts_count}}


> Clean models from unused fields
> -------------------------------
>
>                 Key: ARIA-155
>                 URL: https://issues.apache.org/jira/browse/ARIA-155
>             Project: AriaTosca
>          Issue Type: Task
>            Reporter: Ran Ziv
>            Assignee: Ran Ziv
>            Priority: Minor
>
> Some models have fields which should probably be removed (as they're no longer in use
or haven't been put to use yet) or rename (due to inconsistencies).
> Suggested changes:
> * Service:
>    - remove {{permalink}}
>    - remove {{scaling_groups}}
>  - remove {{modifications}} and {{updates}}
> * Node:
>  - remove {{scaling_groups}}
> * Relationship:
>  - remove {{source_position}}
>  - remove {{target_position}}
> * Operation:
>  - rename {{max_retries}} to {{max_attempts}}
>  - remove {{executor}}
> * OperationTemplate:
>  - remove {{executor}}
> * Execution:
>  - remove {{is_system_workflow}}
> * Task:
>  - rename {{retry_count}} to {{attempts_count}}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message