ariatosca-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARIA-64) Remove PyYaml dependency
Date Wed, 15 Mar 2017 15:16:41 GMT

    [ https://issues.apache.org/jira/browse/ARIA-64?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15926343#comment-15926343
] 

ASF subversion and git services commented on ARIA-64:
-----------------------------------------------------

Commit 9f7c0ce4195206ae61a4d2deaaef6fcc6cafbf4e in incubator-ariatosca's branch refs/heads/ARIA-96-less-strict-dependencies
from [~avia]
[ https://git-wip-us.apache.org/repos/asf?p=incubator-ariatosca.git;h=9f7c0ce ]

Change all requirements to version-agnostic

Except pyyaml, that is supposed to go according to ARIA-64, and
networkx, which requires further investigation.


> Remove PyYaml dependency
> ------------------------
>
>                 Key: ARIA-64
>                 URL: https://issues.apache.org/jira/browse/ARIA-64
>             Project: AriaTosca
>          Issue Type: Task
>            Reporter: Tal Liron
>
> We're using ruamel.yaml: there is no reason to use two separate yaml parsers, and it
indeed can lead to confusion.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message