ariatosca-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From a...@apache.org
Subject [2/3] incubator-ariatosca git commit: Change all requirements to version-agnostic
Date Wed, 15 Mar 2017 15:16:13 GMT
Change all requirements to version-agnostic

Except pyyaml, that is supposed to go according to ARIA-64, and
networkx, which requires further investigation.


Project: http://git-wip-us.apache.org/repos/asf/incubator-ariatosca/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-ariatosca/commit/9f7c0ce4
Tree: http://git-wip-us.apache.org/repos/asf/incubator-ariatosca/tree/9f7c0ce4
Diff: http://git-wip-us.apache.org/repos/asf/incubator-ariatosca/diff/9f7c0ce4

Branch: refs/heads/ARIA-96-less-strict-dependencies
Commit: 9f7c0ce4195206ae61a4d2deaaef6fcc6cafbf4e
Parents: 95177d0
Author: Avia Efrat <avia@gigaspaces.com>
Authored: Thu Mar 9 12:02:06 2017 +0200
Committer: Avia Efrat <avia@gigaspaces.com>
Committed: Wed Mar 15 16:58:36 2017 +0200

----------------------------------------------------------------------
 requirements.txt | 26 +++++++++++++-------------
 1 file changed, 13 insertions(+), 13 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-ariatosca/blob/9f7c0ce4/requirements.txt
----------------------------------------------------------------------
diff --git a/requirements.txt b/requirements.txt
index d6331a5..5844359 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -11,23 +11,23 @@
 # limitations under the License.
 
 PyYAML>=3.10,<=3.12
-requests>=2.7.0,<=2.10.0
+requests
 networkx==1.9
-retrying==1.3.3
-blinker==1.4
+retrying
+blinker
 importlib==1.0.4 ; python_version < '2.7'
 ordereddict==1.1 ; python_version < '2.7'
 total-ordering==0.1.0 ; python_version < '2.7'
 jsonpickle
-ruamel.yaml==0.11.15
-Jinja2==2.8
-shortuuid==0.4.3
-CacheControl[filecache]==0.11.6
-clint==0.5.1
-SQLAlchemy==1.1.4
-wagon==0.5.0
-bottle==0.12.11
-six==1.10.0
-Fabric==1.13.1
+ruamel.yaml
+Jinja2
+shortuuid
+CacheControl[filecache]
+clint
+SQLAlchemy
+wagon
+bottle
+six
+Fabric
 # Fabric makes use of this library, but doesn't bring it :(
 pypiwin32==219 ; sys_platform == 'win32'


Mime
View raw message