ariatosca-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From AviaE <...@git.apache.org>
Subject [GitHub] incubator-ariatosca pull request #152: ARIA-166 Update README file
Date Mon, 12 Jun 2017 11:47:08 GMT
Github user AviaE commented on a diff in the pull request:

    https://github.com/apache/incubator-ariatosca/pull/152#discussion_r121369607
  
    --- Diff: README.md ---
    @@ -4,198 +4,111 @@ ARIA
     [![Build Status](https://travis-ci.org/apache/incubator-ariatosca.svg?branch=master)](https://travis-ci.org/apache/incubator-ariatosca)
     [![Appveyor Build Status](https://ci.appveyor.com/api/projects/status/ltv89jk63ahiu306?svg=true)](https://ci.appveyor.com/project/ApacheSoftwareFoundation/incubator-ariatosca/history)
     [![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://opensource.org/licenses/Apache-2.0)
    +[![PyPI release](https://img.shields.io/pypi/v/ariatosca.svg?style=plastic)](https://pypi.python.org/pypi/ariatosca)
    +![Python Versions](https://img.shields.io/pypi/pyversions/ariatosca.svg?style=plastic)
    +![Wheel](https://img.shields.io/pypi/wheel/ariatosca.svg?style=plastic)
    +![Contributors](https://img.shields.io/github/contributors/apache/incubator-ariatosca.svg?style=plastic)
    +[![Open Pull Requests](https://img.shields.io/github/issues-pr/apache/incubator-ariatosca.svg?style=plastic)](https://github.com/apache/incubator-ariatosca/pulls)
    +[![Closed Pull Requests](https://img.shields.io/github/issues-pr-closed-raw/apache/incubator-ariatosca.svg?style=plastic)](https://github.com/apache/incubator-ariatosca/pulls?q=is%3Apr+is%3Aclosed)
     
     
    -[ARIA](http://ariatosca.org/) is a minimal TOSCA orchestrator, as well as a platform
for building
    -TOSCA-based products. Its features can be accessed via a well-documented Python API.
    +[ARIA](http://ariatosca.incubator.apache.org/) is a an open-source, lightweight, library
and CLI for orchestration that open-source projects can consume to build TOSCA-based orchestration
solutions for resources and services orchestration. It supports NFV and hybrid Cloud scenarios.
     
    -On its own, ARIA provides built-in tools for blueprint validation and for creating ready-to-run
    -service instances. 
    +ARIA can be utilized by any organization that wants to implement TOSCA-based orchestration
in its solutions, whether a multi-cloud enterprise application, or an NFV or SDN solution
for multiple virtual infrastructure managers.
     
    -ARIA adheres strictly and meticulously to the
    -[TOSCA Simple Profile v1.0 cos01 specification](http://docs.oasis-open.org/tosca/TOSCA-Simple-Profile-YAML/v1.0/cos01/TOSCA-Simple-Profile-YAML-v1.0-cos01.html),
    -providing state-of-the-art validation at seven different levels:
    +With ARIA, you can utilize TOSCA's cloud portability out-of-the-box, to test and run
your applications, from template to deployment. 
     
    -<ol start="0">
    -<li>Platform errors. E.g. network, hardware, or even an internal bug in ARIA (let
us know,
    -	please!).</li>
    -<li>Syntax and format errors. E.g. non-compliant YAML, XML, JSON.</li>
    -<li>Field validation. E.g. assigning a string where an integer is expected, using
a list instead of
    -	a dict.</li>
    -<li>Relationships between fields within a type. This is "grammar" as it applies
to rules for
    -    setting the values of fields in relation to each other.</li>
    -<li>Relationships between types. E.g. referring to an unknown type, causing a type
inheritance
    -    loop.</li>
    -<li>Topology. These errors happen if requirements and capabilities cannot be matched
in order to
    -	assemble a valid topology.</li>
    -<li>External dependencies. These errors happen if requirement/capability matching
fails due to
    -    external resources missing, e.g. the lack of a valid virtual machine, API credentials,
etc.
    -    </li> 
    -</ol>
     
    -Validation errors include a plain English message and when relevant the exact location
(file, row,
    -column) of the data the caused the error.
    +Installation
    +----------------
     
    -The ARIA API documentation always links to the relevant section of the specification,
and likewise
    -we provide an annotated version of the specification that links back to the API documentation.
    +ARIA is [available on PyPI](https://pypi.python.org/pypi/ariatosca).    
     
    +ARIA requires Python 2.6/2.7. Python 3+ is not currently supported.
     
    -Quick Start
    ------------
    +ARIA itself is in a `wheel` format compatible with all platforms. 
    +Some dependencies, however, might require compilation (based on a given platform), and
therefore possibly some system dependencies are required as well.
    --- End diff --
    
    Maybe move these 'disclaimers' to the bottom, under troubleshooting or something similar.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message