archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: Archiva 2.2.x, resetting password
Date Thu, 01 Jan 1970 00:00:00 GMT
Hi Thad,

Thad Humphries wrote:

> Okay, I finally found the reset messages and I'm back with new passwords.
> I've also changed security.policy.password.previous.count to 0 and
> restarted. We'll see in another 90 or 180 days.

It seems that the setting in the security.properties will have no effect on 
already existing passwords. It is a flag in the JDOUSER table. However, you 
cannot manually change this flag (I've tried), because it has influence on 
the password's hash value. You can inspect the data record now, if tghe 
value is 0, your password should not expire.

> Very odd, though: When I login as admin, the login dialog does not
> disappear. I have reload the page before I see my admin menu options.
> 
> On Tue, Aug 16, 2016 at 7:08 PM, Thad Humphries <thad.humphries@gmail.com>
> wrote:
> 
>> Thanks. I tried something similar before (see http://www.mail-archive.
>> com/users@archiva.apache.org/msg02910.html) by creating a
>> ~/.m2/security.properties file, but I set
>> security.policy.password.previous.count to -1. Maybe zero will work for
>> me this time.
>>
>> Frankly, I'm not familiar enough with the nits of Archiva administration
>> to follow you on your fix. I am not running  Archiva under Tomcat but
>> simply starting it on port 8080:
>>
>> $ cd /opt/apache-archiva-2.2.0
>> $ nohup bin/archiva console start &
>>
>> I may be stuck rebuilding it (or switching to Nexus).


Actually I was tempted to switch to Nexus also.

Cheers,
Jörg



Mime
View raw message