archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charlie Kim <charl...@yahoo-inc.com.INVALID>
Subject Re: Archvia takes abour 30~50 mins to start up
Date Fri, 18 Mar 2016 15:11:44 GMT
Hi there, any update on this?Thanks.

      From: Charlie Kim <charlesk@yahoo-inc.com>
 To: "users@archiva.apache.org" <users@archiva.apache.org> 
 Sent: Monday, March 14, 2016 5:28 PM
 Subject: Re: Archvia takes abour 30~50 mins to start up
   
Thank Oliver,What about https://github.com/apache/archiva/blob/8c67ef5e755b9569d5b4edeba152a06d6e66443e/archiva-modules/archiva-web/archiva-webapp/src/main/resources/META-INF/spring-context.xml?I
tried commenting those beans but getting bunch exceptions related to failure to create beans.
I change to repositorySessionFactory#file but it still looks like it's using jcr.2016-03-15
00:27:32,921 INFO  [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/]] Initializing
Spring root WebApplicationContext2016-03-15 00:27:41,143 INFO  [org.apache.archiva.metadata.repository.jcr.ArchivaJcrRepositoryConfig]
no repository.xml file in path /home/y/var/yarchiva/conf/repository.xml so use default from
resources path org/apache/archiva/metadata/repository/jcr/repository.xml2016-03-15 00:27:41,258
INFO  [org.apache.jackrabbit.core.RepositoryImpl] Starting repository...2016-03-15 00:27:41,264
INFO  [org.apache.jackrabbit.core.fs.local.LocalFileSystem] LocalFileSystem initialized at
path /home/y/var/yarchiva/data/jcr/repository2016-03-15 00:27:41,394 INFO  [org.apache.jackrabbit.core.fs.local.LocalFileSystem]
LocalFileSystem initialized at path /home/y/var/yarchiva/data/jcr/version2016-03-15 00:27:42,424
INFO  [org.apache.jackrabbit.core.fs.local.LocalFileSystem] LocalFileSystem initialized at
path /home/y/var/yarchiva/data/jcr/version/blobs

      From: Olivier Lamy <olamy@apache.org>
 To: Charlie Kim <charlesk@yahoo-inc.com> 
Cc: "users@archiva.apache.org" <users@archiva.apache.org>
 Sent: Monday, March 14, 2016 5:00 PM
 Subject: Re: Archvia takes abour 30~50 mins to start up
  
Hi
Sorry to not reply faster!!
Yup you can remove content from ${appserver.base}/data/jcr.
You can switch for file based instead of jcr
See WEB-INF/classes/applicationContext.xml
https://github.com/apache/archiva/blob/1.4-M2-RC/archiva-modules%2Farchiva-web%2Farchiva-webapp%2Fsrc%2Fmain%2Fwebapp%2FWEB-INF%2FapplicationContext.xml#L78

replace with <alias name="repositorySessionFactory#file"
alias="repositorySessionFactory"/>

I have never tested that. I think you will have to put manually the jar
from
http://repo.maven.apache.org/maven2/org/apache/archiva/metadata-store-file/1.4-M1/
(as I'm not sure if it's included in the distribution)

HTH
Olivier



On 15 March 2016 at 09:12, Charlie Kim <charlesk@yahoo-inc.com> wrote:

> Hi there again,
>
> How do I disable jcr repository? It seems like its only used for content
> storage Prior to version 1.4-M1
> Do you mean to remove directory ${appserver.base}/data/jcr?
>
>
>
> ------------------------------
> *From:* Charlie Kim <charlesk@yahoo-inc.com>
> *To:* Olivier Lamy <olamy@apache.org>; "users@archiva.apache.org" <
> users@archiva.apache.org>
> *Sent:* Tuesday, March 8, 2016 7:53 AM
> *Subject:* Re: Archvia takes abour 30~50 mins to start up
>
> How do I clean it?
> Also, is there way to disable it from start up?
> Thank
>
>
> ------------------------------
> *From:* Olivier Lamy <olamy@apache.org>
> *To:* users@archiva.apache.org; Charlie Kim <charlesk@yahoo-inc.com>
> *Sent:* Tuesday, March 8, 2016 2:32 AM
> *Subject:* Re: Archvia takes abour 30~50 mins to start up
>
> Hi
> That is definitely not expected
> A workaround is to clean jackarabbit repo.
> But I don't understand why is it used at startup
>
>
> On 3 March 2016 at 04:54, Charlie Kim <charlesk@yahoo-inc.com.invalid>
> wrote:
>
>
> 2016-03-02 02:01:28,258 INFO
> [org.apache.jackrabbit.core.persistence.bundle.AbstractBundlePersistenceManager]
> cachename=defaultBundleCache[ConcurrentCache@3bdcbb49], elements=1626,
> usedmemorykb=8189, maxmemorykb=8192, access=46736, miss=466732016-03-02
> 02:02:28,553 INFO
> [org.apache.jackrabbit.core.persistence.bundle.AbstractBundlePersistenceManager]
> cachename=defaultBundleCache[ConcurrentCache@3bdcbb49], elements=1636,
> usedmemorykb=8188, maxmemorykb=8192, access=51435, miss=513722016-03-02
> 02:03:29,244 INFO
> [org.apache.jackrabbit.core.persistence.bundle.AbstractBundlePersistenceManager]
> cachename=defaultBundleCache[ConcurrentCache@3bdcbb49], elements=1613,
> usedmemorykb=8188, maxmemorykb=8192,
> 2016-03-02 02:28:34,695 INFO  [org.apache.catalina.startup.Catalina]
> Server startup in 2399206 ms
>
> And sda busy goes up to 100% which I think it's doing indexing stuff.Is
> there way to turn this off or configure it to make it run faster?We are
> running with 1.4-M2.Thanks.
>
>
>
>
> --
> Olivier Lamy
> http://twitter.com/olamy | http://linkedin.com/in/olamy
>
>
>
>
>


-- 
Olivier Lamy
http://twitter.com/olamy | http://linkedin.com/in/olamy


   

  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message