archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Agung Dyanjatmiko <adianmik...@gmail.com>
Subject Error when deploy artifact using aether maven plugin
Date Tue, 05 May 2015 05:15:00 GMT
Dear all,

I have probleam when i deploy artifact using aether, the probleam is alwasy
return bad request 400 , but the files that i deploy are sucessfuly
deployed on archiva. the thing that make confused is why arhiva always
returned bad request 400 return code.

this is my log application :


org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer
artifact org.apache.maven.wagon:wagon-ftp-2.8:jar:2.8-20150505.015103-2
from/to snapshots (http://localhost:8080/repository/snapshots): Bad Request
(400)
at
org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:43)
at
org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355)
at
org.eclipse.aether.connector.basic.BasicRepositoryConnector.put(BasicRepositoryConnector.java:274)
at
org.eclipse.aether.internal.impl.DefaultDeployer.deploy(DefaultDeployer.java:311)
at
org.eclipse.aether.internal.impl.DefaultDeployer.deploy(DefaultDeployer.java:245)
at
org.eclipse.aether.internal.impl.DefaultRepositorySystem.deploy(DefaultRepositorySystem.java:413)
at org.eclipse.aether.examples.DeployArtifacts.main(DeployArtifacts.java:69)
Caused by: org.apache.http.client.HttpResponseException: Bad Request (400)
at
org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:458)
at
org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:283)
at
org.eclipse.aether.transport.http.HttpTransporter.implPut(HttpTransporter.java:257)
at
org.eclipse.aether.spi.connector.transport.AbstractTransporter.put(AbstractTransporter.java:117)
at
org.eclipse.aether.connector.basic.BasicRepositoryConnector$PutTaskRunner.runTask(BasicRepositoryConnector.java:510)
at
org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:350)


ARCHIVA log : 2015-05-05 09:38:57,722 [qtp9848867-23] INFO
 org.apache.archiva.security.ArchivaServletAuthenticator [] - Authorization
Denied [ip=127.0.0.1,permission=archiva-upload-repository,repo=snapshots] :
no matching permissions.
Archiva Request Log :

127.0.0.1 -  -  [05/May/2015:02:38:57 +0000] "OPTIONS
/repository/snapshots/org/apache/maven/wagon/wagon-ftp-2.8/2.8-SNAPSHOT/wagon-ftp-2.8-2.8-20150505.023857-3.jar
HTTP/1.1" 404 0 "-" "Aether"
127.0.0.1 -  -  [05/May/2015:02:38:57 +0000] "PUT
/repository/snapshots/org/apache/maven/wagon/wagon-ftp-2.8/2.8-SNAPSHOT/wagon-ftp-2.8-2.8-20150505.023857-3.jar
HTTP/1.1" 401 0 "-" "Aether"


Help me soon... please.

Regard

adian

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message