archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy <ol...@apache.org>
Subject Re: reset password: mail configuration?
Date Mon, 23 Feb 2015 10:26:11 GMT
I recommend you have a look here:
http://archiva.apache.org/redback/configuration.html#Email_Settings

The properties used are: email.from.address and email.from.name

HTH
Olivier

On 20 February 2015 at 19:21, Kristian Rink <kawazu428@gmail.com> wrote:

> Hi Olivier;
>
> and first off, thanks a bunch for your help. Gave it a quick look, read
> through the jetty reference and configured it just like this:
>
>
> <New class="org.eclipse.jetty.jndi.factories.MailSessionReference">
>  <Set name="properties">
>   <New class="java.util.Properties">
>     <Put name="mail.smtp.host">192.168.1.253</Put>
>     <Put name="mail.from">admin@...</Put>
>     <Put name="mail.debug">true</Put>
>   </New>
>  </Set>
> </New>
>
> Outcome: archiva does now try to use the defined MX rather than the local
> transport on its VM to send mails (good), but the "mail.from" parameter
> still is ignored, mail still is trying to be sent as <user>@localhost. Is
> there anything else I am missing here? I do not have user/password set as
> the local hosts do not need to authenticate for sending out...
>
>
> TIA and all the best,
> Kristian
>



-- 
Olivier Lamy
http://twitter.com/olamy | http://linkedin.com/in/olamy

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message