archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Goss, Lucas" <LG...@sheriffleefl.org>
Subject Maven deploy issues
Date Wed, 17 Sep 2014 18:36:48 GMT
I just installed a fresh Archiva standalone app (2.1.1). I followed the documents to deploy
from Maven over HTTP (distributionManagement and repositories) and ran "mvn deploy". The app
is a simple library jar.

I have the settings.xml setup and in my pom.xml I have:
<project ...>
                <groupId>org.sheriffleefl</groupId>
                <artifactId>lib-example</artifactId>
                <version>1.0-SNAPSHOT</version>
                <packaging>jar</packaging>
                <name>lib-example</name>
                <description>Some lib description</description>
                <url>http://localdomain</url>
                ...
                <distributionManagement>
                                <repository>
                                                <id>archiva.internal</id>
                                                <name>lcso-law-enforcement</name>
                                                <url>http://hdq-mvn:8080/repository/internal/</url>
                                </repository>

                                <snapshotRepository>
                                                <id>archiva.snapshots</id>
                                                <name>lcso-law-enforcement</name>
                                                <url>http://hdq-mvn:8080/repository/snapshots/</url>
                                </snapshotRepository>
                </distributionManagement>
                ...
</project>

When the app gets deployed it says it uploaded to the correct location:
Uploaded: http://localdomain:8080/repository/snapshots/org/sheriffleefl/lib-example/1.0-SNAPSHOT/lib-example-1.0-20140917-1.jar
...

The output from mvn is successful, but then when I browse the Archiva site, the artifact doesn't
show up (checked all, snapshot, etc.). So I did a search and searched for part of the artifact
name, "lib", and it comes up in the search result grid:
name: l
artifact id: lib-example
version 1.0-SNAPSHOT

But if I click on the artifact "lib-example", no "Versions" exist, and the artifact info only
has "Artifact ID" and just one letter in the "Group ID", everything else is empty and the
group is wrong. If I go up a directory (using breadcrumbs) to the "l" (group id) nothing shows
up in that directory. If I upload it through the web interface I have the same issue. The
first time I did this same process and the upload through the web ui worked correctly I believe.
Now the only way I can find the uploaded artifact is to go directly to the artifact name (breadcrumbs
work on the one uploaded from the web):
localdomain:8080/#artifact/org.sheriffleefl/lib-example

Is there something I am missing? Or is something missing from the documentation? I've also
tried Index and Directory scanning and it doesn't help, but it does make the search not work
for anything (can't find either the Maven deployed app or the web uploaded app).

Lucas


***IMPORTANT MESSAGE***
This message is intended for the use of the person or entity to whom it is addressed and may
contain information that is privileged and confidential, the disclosure of which is governed
by applicable law. If the reader of this email is not the intended recipient or the employee
or agent responsible to deliver it to the intended recipient, you are hereby notified that
any dissemination, distribution or copying of this information is STRICTLY PROHIBITED. If
you have received this email by error, please notify us immediately and destroy the related
message. This footnote also confirms that this email message has been swept for the presence
of computer viruses, worms, hostile scripts and other email-borne network threats. PLEASE
NOTE: Florida has a very broad public records law. Most written communications to or from
government officials are public records available to the public and media upon request. Your
email communications may be subject to public disclosure per Sec. 119 F.S.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message