archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Sharp <forjsh...@gmail.com>
Subject Re: LDAP groups
Date Thu, 03 Jul 2014 16:53:53 GMT
Hey Bill,

Your email came through. While the LDAP directories RedBack is tested
against probably all conform by default to the schema defined in RFC
4519... http://www.rfc-editor.org/rfc/rfc4519.txt ... Active Directory
deployments typically do not use all of the classes or populate attributes
in the way one would normally anticipate.

You might try adding the following to the properties file:
ldap.config.groups.class=group

-Jon


On Thu, Jul 3, 2014 at 8:37 AM, Bill Spens <billspens@gmail.com> wrote:

> I'm not sure if my first post went though since I was not subscribed to the
> group when I posted.  Sorry if this is a duplicate.
>
>
>
> I'm trying to understand how to get ldap groups to show up in the GUI.  I
> see in the code references to "LDAP_GROUPS_ROLE_START_KEY" and
> "ldap.config.groups.role.".  It looks like the reason my groups are not
> showing up because they must begin with something specific.
>
>
>
> What is the default value and how do I change it?  For example, I want my
> ldap group "developers' to show up in the list and map that to 'Registered
> User'.  Right now, nothing is showing up in the drop down list on the ldap
> group/role mapping screen and nothing I enter in the filter causes anything
> to happen.  I've tried to find more details in the admin guide and a few
> other places, but I must be missing something simple here.
>
>
>
> Thanks for any suggestions,
>
> Bill
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message