archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stallard,David" <stall...@oclc.org>
Subject Re: 405 error when uploading to Archiva 2.0.1
Date Mon, 02 Jun 2014 14:15:04 GMT
If I want to change the context back to what it was previously so that our
URLs don’t change, is there something else I need to do besides modify
contexts/archiva.xml?  I changed the contextPath from “/“ to “/archiva”
but that gives me a 404 that there is no known context.


On 5/30/14, 1:27 AM, "Olivier Lamy" <olamy@apache.org> wrote:

>Note: per default archiva is now on root context.
>See http://archiva.apache.org/docs/2.0.1/adminguide/upgrade.html
>section "Updated Jetty configuration"
>
>HTH
>Olivier
>
>On 30 May 2014 07:28, Stallard,David <stallard@oclc.org> wrote:
>> It turns out that the URLs are slightly different.  In our 1.3.5
>>instance
>> with tomcat the URLs look like this:
>>
>> http://server:port/archiva/repository/internal/...
>>
>> But in the 2.0.1 instance with jetty it looks like this (no ³archiva²
>> string):
>>
>> http://server:port/repository/internal/Š
>>
>> I don¹t know if the string ³archiva² is an inherent difference between
>> 1.3.5 and 2.0.1, or if it¹s a difference between our tomcat setup and
>>our
>> jetty setup.  I browsed the 2.0.1 config files a bit but didn¹t see
>>where
>> this might be defined.
>>
>> Once we changed our maven settings.xml to remove ³archiva² from the URL,
>> the 405 error went away.  It was replaced with a 401, but hopefully now
>> that is something we can work through.
>>
>>
>>
>> On 5/29/14, 11:34 AM, "Pimentel, Robert" <Robert.Pimentel@tgslc.org>
>>wrote:
>>
>>>Is it using the appropriate URL value? Can you provide the error stack
>>>from maven (mvn -e)? Can you provide a snippet from the Archiva log(s)?
>>>
>>>Thanks,
>>>Rob
>>>
>>>-----Original Message-----
>>>From: Stallard,David [mailto:stallard@oclc.org]
>>>Sent: Thursday, May 29, 2014 10:24 AM
>>>To: users@archiva.apache.org
>>>Subject: Re: 405 error when uploading to Archiva 2.0.1
>>>
>>>Just to add to the below, uploads are working fine through the web
>>>interface but we get the http 405 error when a maven build tries to
>>>upload.  Downloads are working fine as well.
>>>
>>>Thanks,
>>>David
>>>
>>>From: <Stallard>, "Stallard,David"
>>><stallard@oclc.org<mailto:stallard@oclc.org>>
>>>Date: Tuesday, May 27, 2014 at 2:03 PM
>>>To: "users@archiva.apache.org<mailto:users@archiva.apache.org>"
>>><users@archiva.apache.org<mailto:users@archiva.apache.org>>
>>>Subject: 405 error when uploading to Archiva 2.0.1
>>>
>>>We are trying to test a maven deploy against our test instance of
>>>Archiva
>>>2.0.1, but we are getting http 405 when the build attempts to upload an
>>>artifact.  It looks like 405 means that the upload method was not
>>>allowed.
>>>
>>>The new instance is running on the same port as our live instance of
>>>Archiva 1.3.5 (different host though), so I don't think the application
>>>being built has a port number that needs to be changed.  The main
>>>difference is that 1.3.5 is running with tomcat and 2.0.1 is using the
>>>included jetty.  Could we be missing some setting in jetty.xml which is
>>>set correctly in our 1.3.5 instance?  Any other ideas?
>>>
>>>Thanks,
>>>David
>>>
>>
>>
>
>
>
>-- 
>Olivier Lamy
>Ecetera: http://ecetera.com.au
>http://twitter.com/olamy | http://linkedin.com/in/olamy

Mime
View raw message