archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Innerebner <markus.innereb...@eurac.edu>
Subject Re: Question about external repositories
Date Fri, 29 Nov 2013 16:24:38 GMT
Hi , thanks for you prompt answer:

I guess you mean the settings.xml of the client: I only touched the part 
about the mirrors.

<?xml version="1.0" encoding="UTF-8"?>
<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
           xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 
http://maven.apache.org/xsd/settings-1.0.0.xsd">
   <pluginGroups>
   </pluginGroups>

   <proxies>
   </proxies>

   <servers>
   </servers>

   <mirrors>
*    <mirror>**
**      <id>archiva.default</id>**
**<url>http://abz01sde.eurac.edu:8080/archiva/repository/internal</url>**
**      <mirrorOf>external:*</mirrorOf>**
**    </mirror>**
**    <mirror>**
**      <id>archiva.apache.snapshot</id>**
**<url>http://abz01sde.eurac.edu:8080/archiva/repository/snapshots</url>**
**      <mirrorOf>apache.snapshots</mirrorOf>**
**    </mirror>*
   </mirrors>

   <profiles>
   </profiles>
</settings>



> Your expectations are correct, and it works for us exactly that way.
>
> Can you show us the POM your using, the settings.xml involved and the
> exact error messages Maven gives you?

this is the error log:


[AdminInM@ABZ01SDE test]$ mvn clean install
[INFO] Scanning for projects...
[WARNING]
[WARNING] Some problems were encountered while building the effective 
model for edu.eurac.test:test:jar:1.0
[WARNING] 'build.plugins.plugin.version' for 
org.apache.maven.plugins:maven-compiler-plugin is missing. @ line 14, 
column 12
[WARNING]
[WARNING] It is highly recommended to fix these problems because they 
threaten the stability of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support 
building such malformed projects.
[WARNING]
[INFO]
[INFO] 
------------------------------------------------------------------------
[INFO] Building Simple WebGIS Template 1.0
[INFO] 
------------------------------------------------------------------------
[WARNING] The POM for it.geosolutions:geoserver-manager:jar:1.5.0 is 
missing, no dependency information available
[INFO] 
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] 
------------------------------------------------------------------------
[INFO] Total time: 0.682s
[INFO] Finished at: Fri Nov 29 17:21:39 CET 2013
[INFO] Final Memory: 5M/15M
[INFO] 
------------------------------------------------------------------------
[ERROR] Failed to execute goal on project test: Could not resolve 
dependencies for project edu.eurac.test:test:jar:1.0: Failure to find 
it.geosolutions:geoserver-manager:jar:1.5.0 in 
http://abz01sde.eurac.edu:8080/archiva/repository/internal was cached in 
the local repository, resolution will not be reattempted until the 
update interval of archiva.default has elapsed or updates are forced -> 
[Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the 
-e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, 
please read the following articles:
[ERROR] [Help 1] 
http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException


cheers Markus

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message