archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harris, Christopher P" <chris_har...@baxter.com>
Subject Having trouble configuring older snapshots to be deleted
Date Wed, 25 Sep 2013 04:54:44 GMT
Hi.

I'm using the .war version of Archiva 1.4-M4, which is running on Tomcat 7.0.42 and using
PostgreSQL 9.2 as the back-end for Jackrabbit.

I have set up snapshots repository that houses snapshots of internal artifacts.  I have also
set up Jenkins.  Every time Jenkins successfully builds one of our internal projects from
our trunk, it then deploys the snapshot to Archiva.  This particular snapshot repo keeps accumulating
artifacts.

I've reviewed the Archiva doc on repository configuration surrounding "Days Older" and "Retention
Count".  I've set both to 2.  The Snapshots, Scanned, and Delete Released Snapshots are the
only check boxes that are checked.

To hone in on one example snapshot artifact, I see that the numbering of snapshot artifacts
is 20-24.  It should 23 & 24 only.

How can I resolve this problem?
The information transmitted is intended only for the person(s) or entity to which it is addressed
and may contain confidential and/or legally privileged material. Delivery of this message
to any person other than the intended recipient(s) is not intended in any way to waive privilege
or confidentiality. Any review, retransmission, dissemination or other use of, or taking of
any action in reliance upon, this information by entities other than the intended recipient
is prohibited. If you receive this in error, please contact the sender and delete the material
from any computer.

For Translation:

http://www.baxter.com/email_disclaimer


Mime
View raw message