archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Kim <charl...@yahoo-inc.com>
Subject RE: Denied Access to remote repo
Date Thu, 29 Aug 2013 21:56:01 GMT
It turns out that empty user-agent header would cause this.

[charlesk@readproud ~]$ curl -v --header "User-Agent: " http://repo1.maven.org/maven2/commons-daemon/commons-daemon/1.0.6/commons-daemon-1.0.6.pom
* About to connect() to repo1.maven.org port 80 (#0)
*   Trying 199.27.77.184... connected
* Connected to repo1.maven.org (199.27.77.184) port 80 (#0)
> GET /maven2/commons-daemon/commons-daemon/1.0.6/commons-daemon-1.0.6.pom HTTP/1.1
> Host: repo1.maven.org
> Accept: */*
> 
< HTTP/1.1 403 Denied Access
< Server: Varnish
< Retry-After: 0
< Content-Type: text/html; charset=utf-8
< Content-Length: 401
< Accept-Ranges: bytes
< Date: Thu, 29 Aug 2013 21:39:55 GMT
< Via: 1.1 varnish
< Age: 0
< Connection: close
< X-Served-By: cache-sv62-SJC3
< X-Cache: MISS
< X-Cache-Hits: 0
<

This is what I see in org.apache.maven.wagon.shared.http.AbstractHttpClientWagon
{http.useragent=null, http.protocol.content-charset=ISO-8859-1, http.protocol.version=HTTP/1.1,
http.protocol.cookie-policy=compatibility, http.tcp.nodelay=true, http.socket.buffer-size=8192}


-----Original Message-----
From: Charles Kim [mailto:charlesk@yahoo-inc.com] 
Sent: Thursday, August 29, 2013 1:52 PM
To: users@archiva.apache.org
Subject: RE: Denied Access to remote repo

We are currently using 1.4-M2.
Furthering testing shows that this is only happening with the wagon provider plus central
repo. Other repos such as codehaus works fine with the wagon provider.  

Same artifact request works with HttpURLConnection.

Also, unit test for Archiva Web fails.

[INFO] Building Archiva Web :: Application 1.4-M2 Tests in error: 
  downloadWithRemoteRedirect(org.apache.archiva.DownloadArtifactsTest): Failed to transfer
file: http://localhost:39187//repository/internal/junit/junit/4.9/junit-4.9.jar. Return code
is: 500, ReasonPhrase:Unable to fetch artifact resource..

Tests run: 201, Failures: 0, Errors: 1, Skipped: 0


Also, here is the connection info to central repo from the Archiva machine.
[charlesk@readproud ~]$ telnet central.maven.org 80 Trying 199.27.77.184...
Connected to central.maven.org (199.27.77.184).
Escape character is '^]'.

Does anyone else have similar issue?

-----Original Message-----
From: Brett Porter [mailto:brett@porterclan.net] On Behalf Of Brett Porter
Sent: Tuesday, August 27, 2013 5:59 PM
To: users@archiva.apache.org
Subject: Re: Denied Access to remote repo

Is any of your configuration using a proxy server that might be denying access? I can't think
of any other reason.

Which version of Archiva are you using?

Regards,
Brett

On 28/08/2013, at 9:17 AM, Charles Kim <charlesk@yahoo-inc.com> wrote:

> We are starting to get denied access error from the central repo while doing curl from
the same machine seems to work.  Is there anything that might cause Archiva to behave this
way?  We have noticed the problem today.
> 
> Error message: Download failure on resource [http://repo1.maven.org/maven2/commons-daemon/commons-daemon/1.0.6/commons-daemon-1.0.6.pom]:Access
denied to: http://repo1.maven.org/maven2/commons-daemon/commons-daemon/1.0.6/commons-daemon-1.0.6.pom,
ReasonPhrase:Denied Access.
> 2013-08-27 23:04:41,609 ERROR [org.apache.archiva.webdav.ArchivaDavResourceFactory] Failures
occurred downloading from some remote repositories:
>        central: Download failure on resource [http://repo1.maven.org/maven2/commons-daemon/commons-daemon/1.0.6/commons-daemon-1.0.6.pom]:Access
denied to: http://repo1.maven.org/maven2/commons-daemon/commons-daemon/1.0.6/commons-daemon-1.0.6.pom,
ReasonPhrase:Denied Access.
> org.apache.archiva.policies.ProxyDownloadException: Failures occurred downloading from
some remote repositories:
>        central: Download failure on resource [http://repo1.maven.org/maven2/commons-daemon/commons-daemon/1.0.6/commons-daemon-1.0.6.pom]:Access
denied to: http://repo1.maven.org/maven2/commons-daemon/commons-daemon/1.0.6/commons-daemon-1.0.6.pom,
ReasonPhrase:Denied Access.
> 
> 
> -bash-4.1$ curl -v 
> http://repo1.maven.org/maven2/commons-daemon/commons-daemon/1.0.6/comm
> ons-daemon-1.0.6.pom
> * About to connect() to repo1.maven.org port 80 (#0)
> *   Trying 199.27.77.185... connected
> * Connected to repo1.maven.org (199.27.77.185) port 80 (#0)
>> GET 
>> /maven2/commons-daemon/commons-daemon/1.0.6/commons-daemon-1.0.6.pom 
>> HTTP/1.1
>> User-Agent: curl/7.21.7 (x86_64-unknown-linux-gnu) libcurl/7.21.7 
>> OpenSSL/0.9.8o zlib/1.2.3 libidn/1.18 libssh2/1.2.2
>> Host: repo1.maven.org
>> Accept: */*
>> 
> < HTTP/1.1 200 OK

--
Brett Porter   @brettporter
http://brettporter.wordpress.com/
http://au.linkedin.com/in/brettporter


Mime
View raw message