archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lothar Werzinger <lot...@tradescape.biz>
Subject URL in search results for SNAPSHOTS does not work
Date Wed, 29 May 2013 00:15:36 GMT
Hi,

I am researching Archiva and I tried using the REST API for Archiva 1.4.

I am using 1.4-M3 as well as the staged 1.4-M4 from
https://dist.apache.org/repos/dist/dev/archiva/1.4-M4


When I call the *archivaServices/searchService/searchArtifacts* REST API
the returned 'url' field contains a URL that does not work if the searched
artifact is a SNAPSHOT.

Example:

Search returns

    "url": "
http://localhost:8080/repository/activities-snapshots/biz/tradescape/activities/pcs_poc2/pcs_poc2.ccc/0.3-SNAPSHOT/pcs_poc2.ccc-0.3-SNAPSHOT.jar
"

If I take that URL and paste it into a browser I get:

HTTP ERROR 404

Problem accessing
/repository/activities-snapshots/biz/tradescape/activities/pcs_poc2/pcs_poc2.ccc/0.3-SNAPSHOT/pcs_poc2.ccc-0.3-SNAPSHOT.jar.
Reason:

    Resource does not exist


P.S.
Is there an API to get the md5 checksum for an artifact?
It would be nice if the search result would contain a 'md5sum' field.

Thanks in advance!
-- 

Lothar Werzinger

Principal Architect

Tradescape, Inc. - Enabling Efficient Digital Marketplaces

+1-650-931-6719 (direct)

+1-800-697-6068 (main) Ext. 116

lothar@tradescape.biz

http://www.tradescape.biz

-- 


This message and any attachment (the "message") is intended solely for the 
addressees and is confidential. If you receive this message by mistake, 
please delete it and notify the sender immediately. Any use not 
in accordance with its purpose, any out-spread or disclosure, either as a 
whole or partially, is prohibited except with formal approval. Internet 
cannot guarantee the integrity of this message, therefore Tradescape will 
not be liable for the message if modified.

-

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message