archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Barboni" <sk...@apache.org>
Subject RE: Slow download artifacts from apache archiva using apache maven
Date Wed, 29 May 2013 12:55:01 GMT
Hi,

 The speed and download rate given by maven is not pure download it depends
of time to resolve among repository list:
     If one repository is dead it can slowdown overall dl time and rate.
(If the issue suddenly appears )
   
  I'm not really efficient in archiva 1.3.5


-----Message d'origine-----
De : Olivier Lamy [mailto:olamy@apache.org] 
Envoyé : mercredi 29 mai 2013 11:53
À : users@archiva.apache.org
Objet : Re: Slow download artifacts from apache archiva using apache maven

what is the speed with curl ?
curl
http://10.10.1.10:8080/archiva/repository/lima/commons-httpclient/commons-ht
tpclient/3.1/commons-httpclient-3.1.pom

Having a difference between using a browser and something doesn't make sense
(at least for me :-) ).

Is there any huge load on archive server side ?


2013/5/29 Fred Duarte <fduartej@gmail.com>:
> This is an resume about our architecture, we have two archiva setting 
> in our company, one is located in USA and the other in Lima, Peru, 
> both have public external third party repositories like maven central, 
> jboss, spring etc and also we have internal too, this latest 
> repository is used in order to deploy our own components, the main 
> internal is located in USA and the internal Lima repository conect to 
> USA in order to find and download our own components.
>
> Architecture USA
>      external (Public repositories time out is setting by default 60)
>      internal (Our Main repository for our own artifacts)
>      usa (virtual repository for mirror the order in this is first 
> external then internal)
>      hudson (used to build our own artifacts and deploy in USA 
> environment and use maven)
>      maven (connect to archiva using mirror usa)
>
> Architecture Lima
>     external (Public repositories  time out is setting by default 60 
> and external USA time out is 5 seconds setting)
>     internal (internal USA repository time out is 5 seconds setting)
>     lima (virtual repository for mirror the order of the repositories 
> is first external then internal)
>     hudson slave (used to deploy in lima environment and publish 
> artifacts in USA internal)
>     maven (connect to archiva using mirror lima)
>     developers (conect to archiva using mirror lima)
>
> When the developers and hudson too, try to dowload artifacs from lima 
> virtual repository using maven and eclipse it is too slowly but when 
> the artifact is download from the archiva browser it is faster than 
> the used through maven or eclipse maybe this is because when the 
> artifacts is downloaded not only download the file also it download 
> the pom file and their dependencies.
>
> Here some examples
>
> Downloaded:
> http://10.10.1.10:8080/archiva/repository/lima/org/springframework/spr
> ing-asm/3.0.5.RELEASE/spring-asm-3.0.5.RELEASE.pom
> (2 KB at 0.1 KB/sec)
>
> Downloaded:
> http://10.10.1.10:8080/archiva/repository/lima/commons-httpclient/comm
> ons-httpclient/3.1/commons-httpclient-3.1.pom
> (8 KB at 0.4 KB/sec)
>
>
> As you can see the speed of the downloading is too slowly less than 1 
> KB but when I use WinSCP it download at 14Kb by second.
>
> I hope that you can help me thanks, I attached our archiva settings in 
> usa and lima and archiva version is 1.3.5
>
>
>
>
> 2013/5/28 Deng Ching-Mallete <odeaching@gmail.com>
>>
>> Hi Fred,
>>
>> Do you have any remote repository proxies configured in Archiva? If 
>> yes, can you provide the configuration? It's possible that one of the 
>> remote repos is down and the timeout period is long..
>>
>> Thanks,
>> Deng
>>
>>
>> On Tue, May 28, 2013 at 11:37 AM, Fred Duarte <fduartej@gmail.com> wrote:
>>
>> > Hi
>> >
>> > I have been getting some issues with the speed of download of the 
>> > artifacts, the problem happen when I tried to get an artifact using 
>> > maven the speed of download is less than an one kb but when I try 
>> > to download the artifact using the browser it is more greater than 
>> > the maven tool.
>> >
>> > I do not know, what is the problem with it or what happen with the 
>> > currently setting, maybe I have to check an special file or setting 
>> > an advance setting on the file please could you help me in order to 
>> > improve the speed of download.
>> >
>> > Thanks
>> > Fred Duarte
>> >
>>
>>
>>
>> --
>> Maria Odea "Deng" Ching-Mallete | oching@apache.org | 
>> http://www.linkedin.com/in/oching
>
>
>
>
> --
> Regards,
> Fred Duarte



--
Olivier Lamy
Ecetera: http://ecetera.com.au
http://twitter.com/olamy | http://linkedin.com/in/olamy


Mime
View raw message