archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julien Béti <julien.b...@cosium.com>
Subject Upgrading to 1.4-M3 questions (MRM-1643 issue)
Date Mon, 15 Oct 2012 08:48:58 GMT
Hello,

I have installed Archiva 1.3.5 on Debian Squeeze using Tomcat 6.0.35 and 
PostgreSQL 9.1, and I'm facing the issue reported ad MRM-1643 Error 500 
when browsing artefact group [1].

The solution would be to move to version 1.4-M3, but I has this Maven 
Repository is to be used in a production environment, I would like to 
ask few questions:

- Is the LDAP support have been successfully tested yet? Looking at the 
current version of the "./WEB-INF/applicationContext.xml" file, the LDAP 
support seem to haven't been fully migrated (see TODO comment of Olivier 
Lamy).

- Do you think the upgrade from 1.4-M3 and later preview version to the 
official one would be fully supported, or is there a major risk of 
painful  upgrade?

- The 1.3.x version used to use 2 databases: one for users and one for 
artefacts. Browsing the 1.4-M3 documentation, the artifacts database is 
obviously gone [2]. If true, where the artefacts information is now 
stored? When upgrading from 1.3.x to 1.4-M3, is the current artefacts 
information kept?

- Finally, do you have an idea when the official 1.4 release will be 
out? I imagine that's a very frequent question, but I' haven't found the 
information on the website nor on Jira, sorry if I missed it ;-)

Thank you for your support,

Kind Regards,

Julien Béti.

[1] http://jira.codehaus.org/browse/MRM-1643
[2] https://archiva.apache.org/docs/1.4-M3/adminguide/databases.html

Mime
View raw message